php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38305 unable to subscribe to mailing lists
Submitted: 2006-08-03 03:54 UTC Modified: 2006-09-14 18:21 UTC
Votes:14
Avg. Score:3.7 ± 1.6
Reproduced:11 of 13 (84.6%)
Same Version:5 (45.5%)
Same OS:6 (54.5%)
From: pear dot user at gmail dot com Assigned:
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2006-08-03 03:54 UTC] pear dot user at gmail dot com
Description:
------------
A month ago, I created an account - pear.user@gmail.com - in an attempt to sign up for the PEAR mailing lists.  I've since tried, multiple times, to sign up, and have been unable to do so.  I've emailed systems@php.net twice and have heard nothing.

The password to my account - pear.user@gmail.com - is pass12.  Feel free to log in and verify the problem for yourself.  The Sent Mail folder and my Inbox document my attempts.

Now, I'm sure that whomever reads this will not have this problem when they try to register, but that's not of much help to me...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-04 17:43 UTC] pear dot user at gmail dot com
I see that 1 of 3 people have managed to reproduce this, yet I don't see any "WELCOME to pear-dev@lists.php.net" email in pear.user@gmail.com's inbox.  Are people deleting this email?  Or maybe they're just not reproducing this problem as faithfully as they should be?

There's no excuse for the latter since I provide the username *and* password.  If it's the former, then maybe someone would be so kind as to say something.

Further, unless you're going to *give* me your email account, I'm not really interested in whether or not other email accounts can get subscribed.  The point is *I* can't.  And this is far from the first account I've tried to subscribe with (indeed, the creation of an account who's password I was willing to give away freely was the culmination of earlier - failed - attempts to subscribe)
 [2006-08-05 15:17 UTC] rasmus@php.net
We are not going to debug gmail for you.  I did a test where I simply sent a message to pear-general-subscribe@lists.php.net with the word "subscribe" in the subject.  Then when I got the confirmation email, I replied to that and a minute later I got a message with:

Acknowledgment: I have added the address

   rasmus@lerdorf.com

to the pear-general mailing list.

Welcome to pear-general@lists.php.net!

Please save this message so that you know the address you are
subscribed under, in case you later want to unsubscribe or change your
subscription address.

To unsubscribe, send a message to:

  <pear-general-unsubscribe-rasmus=lerdorf.com@lists.php.net>

Why it doesn't work from gmail, I have no idea.  Dozens of people subscribe and unsubscribe every day.  They manage to figure it out.
 [2006-08-06 00:53 UTC] pear dot user at gmail dot com
I've tried this with Yahoo! accounts, as well, without much luck.

Regardless, I've just created a pear.user@yahoo.com and pear.user@hotmail.com account.  Their passwords are the same as pear.user@gmail.com's password.  Hopefully I'll have better luck with these.

I've also contacted the Gmail Team at Google informing them that they have a potential problem on their end.  Whether or not they actually have such a problem is something they'll be far better able to determine than me.
 [2006-08-06 00:59 UTC] pear dot user at gmail dot com
"They manage to figure it out."

If the problem is with gmail, there's not much to "figure out".  If it's just that I'm incompetent, it can be proved quite easily by simply signing pear.user@gmail.com up...
 [2006-08-14 07:15 UTC] cweldon at cerberusonline dot com
I'm having problems as well with several of my email accounts, only one of which is gmail. This happens with the following lists:

1) internals
2) general
3) php-doc
4) announce

I get a confirmation when I use the web form (or if I send an email), but when I reply (either just using reply and sending what's in it by default or sending a blank reply as the instructions state), I get no confirmation that I was subscribed.
 [2006-08-14 14:17 UTC] pear dot user at gmail dot com
I've tried more accounts as well, to no avail.

The emails / passwords of these accounts are all as follows:

pear.user@gmail.com / pass12
pear.user@hotmail.com / pass12
pear.user@yahoo.com / pass12

I get bounced emails at the hotmail.com address and nothing from the other two.

I've tried replying to the message, I've tried sending the message to pear-general-request@lists.php.net with the originating email as the subject line, I've tried sending a messages to pear-general-help@lists.php.net, to pear-general-subscribe@lists.php.net, to pear-general-unsubscribe@lists.php.net, to pear-general-owner@lists.php.net, and to systems@php.net (all of which can be verified by logging into any of the three accounts).

I was planning on sending two emails to each of the emails listed in the initial email one gets from the web form before reposting here, but I am, never-the-less, already convinced that the problem is php.net's.  And if it isn't, there's an easy way to prove that, as well - just subscribe me.  I'm not posting my the passwords to my account for fun - I'm posting them so whomever might attempt to fix the problem can see the exact messages I'm getting - headers and all - and so that they can reproduce my situation much more faithfully.
 [2006-08-15 03:29 UTC] rasmus@php.net
I just checked the logs.  There have been lots of subscribes and unsubscribes from gmail users over the past week including a couple today.  I see nothing wrong on our end.
 [2006-08-15 06:15 UTC] wez@php.net
I've poked around a lot tonight and can't find any definitive reason for this.  I have observed that gmail appear to be blocking our challenge-response mails (there's a build up of those in our spool, but not other mail for gmail is blocked).

I'm not saying that that is the cause, but that we can't find conclusive proof either way.


 [2006-08-15 14:46 UTC] pear dot user at gmail dot com
I was actually thinking that, atleast in my case, since I'm having the problem with yahoo and hotmail, as well, that maybe I've somehow gotten emails from my IP banned?

I've tried two different IP addresses, but maybe ezmlm goes a little overboard in its banning and bans all IPs connecting to failed emails and bans all emails comming from banned IPs?
 [2006-08-15 19:21 UTC] cweldon at cerberusonline dot com
How about my addresses not getting through. The two I'm sending from are:

cweldon@cerberusonline.com
neraath@bowzer.tamu.edu

I have not seen any responses from php.net on either system. The cerberusonline.com address is it's own relay. The bowzer.tamu.edu address sits behind a primary relay, but is a mailhost on its own.

Do you see any records from either of those addresses? I don't have firewall rules blocking either.
 [2006-08-15 19:37 UTC] wez@php.net
cweldon at cerberusonline dot com:

I see a couple of log entries that indicate that mail to you previously could not be delivered and timed out from our queues.  I just tried to send you two messages and they appear to have gone through ok.
 [2006-08-15 19:52 UTC] cweldon at cerberusonline dot com
Okay, so here's what I see on my logs now:

On August 13th between 22:00 and 22:30 CST I received messages from the list system asking me for confirmation to subscribe. I promptly sent back replies. Starting at 23:05 I get the following:

2006-08-13 23:05:18 1GCTcg-00072n-4t SMTP data timeout (message abandoned) on connection from lists.php.net [216.92.131.4]

The next entry from php.net is here:

2006-08-14 00:30:18 1GCUww-0007Ft-DW SMTP data timeout (message abandoned) on connection from lists.php.net [216.92.131.4]

This is on the relay for cerberusonline.com. It's not a high traffic server, but the messages to me seem too ambiguous to determine where the problem is at.
 [2006-08-15 19:59 UTC] wez@php.net
All I can suggest is that you try again to see if it's working now.
 [2006-08-15 20:26 UTC] cweldon at cerberusonline dot com
Okay, I have a second relay that's emitting the same error message as before, which is starting to lead me to believe it's a lists.php.net server issue.

2006-08-15 15:10:00 1GD5Ee-0005nF-6M <= chris@chrisweldon.net U=bowzer2 P=local S=810 id=4755.127.0.0.1.1155672600.squirrel@server2.cerberusonline.com
2006-08-15 15:10:07 1GD5Ee-0005nF-6M => internals-subscribe@lists.php.net R=lookuphost T=remote_smtp H=pair1.php.net [216.92.131.4]

2006-08-15 15:15:09 1GD5En-0005ng-JV SMTP data timeout (message abandoned) on connection from (lists.php.net) [216.92.131.4] F=<confirm-sender-bounce-d5c101526e6f68694a1f4e43e61350b8-chris=chrisweldon.net@lists.php.net>

Again, these messages were just pulled from a different server than the cweldon at cerberusonline.com relay.
 [2006-08-16 19:31 UTC] cweldon at cerberusonline dot com
Anybody have any updates for this?
 [2006-08-20 01:44 UTC] pear dot user at gmail dot com
mj@php.net, in a post on the PEAR Dev mailing lists, suggests that php.net uses a spam blacklist:

http://news.php.net/php.pear.dev/43736

Is it possible that I have been placed on a spam blacklist?
 [2006-08-20 14:15 UTC] wez@php.net
Just FYI, I did find an issue with the challenge/response mail that prevented it from sending properly.
This was resolved a couple of days ago.
If you keep trying to send you'll trigger the box to issue another challenge and you should be golden from there.
 [2006-08-21 17:55 UTC] texmckloud at yahoo dot com
I've had the same experience with three email accounts. I am trying to join php-general. I receive the first confirmation. I reply, but receive nothing after that. 
I have also tried using the other mirrors (us2 and us3), but same problem.

I've verified that my SPAM filters are not dropping them in the bit bucket. I have no blacklists configured. 

If possible, manually add texmckloud@yahoo.com on the php-general mailing list. 

Regards;
Tex
 [2006-08-21 18:15 UTC] pear dot user at gmail dot com
Would being manually added be sufficient?  I mean, if all you're looking to do is to read the stuff on the PEAR mailing lists, being added would be sufficient, but what if you're looking to post there?  You'd have to send messages to pear-general@lists.php.net and if you can't send messages to any *.php.net email address, then being manually added is probably not going to do much to fix that...
 [2006-08-23 22:54 UTC] cweldon at cerberusonline dot com
Still unable to subscribe. I'm still able to get the initial email with respect to wanting to confirm that I sent the subscription request, but now when I send the reply to that email out I'm no longer even seeing attempts coming back from the php.net servers for confirmation of subscription.
 [2006-08-24 18:12 UTC] pear dot user at gmail dot com
Same here.

And I don't think anyone (other than myself) has even bothered to log into any of the three accounts whose passwords I've posted publically.  Which means that I can try even more email addresses or maybe just offer to pay someone to subscribe me...
 [2006-08-26 23:22 UTC] cweldon at cerberusonline dot com
I'm still not getting anything on this. Does anyone have any updates or notifications on progress they are making with this?
 [2006-08-26 23:24 UTC] wez@php.net
I haven't had time to look any deeper just yet, I've been very busy.

 [2006-09-02 16:30 UTC] rocco dot dileo at gmail dot com
I have the same problem signing up using gmail. 

Same as with the other people here, I get the confirm-email and upon reply i get no new feedback. I tried to reply with the Gmail's Reply button, manually compose a message and by using the alternative ways shown in the initial confirm mail. No Luck.

IS there any solution to this problem?
 [2006-09-02 17:55 UTC] rocco dot dileo at gmail dot com
Just for the record. I just tried replying to the confirm-email by using a php script on a server rather than by using the google-mail webapplication. Still no result from the listbot. So i assume that maybe google-mails are somehow blacklisted upon final confirmation, maybe it's the format of the mail as mine is as well firstname.lastname@gmail.com 

Rocco
 [2006-09-04 22:45 UTC] wez@php.net
The issue that I found on Aug 20th was still the cause of the problem; I missed out a vital .so file when correcting the problem last time around.  Sorry about that; it's what happens when you're busy and distracted.

I've done a thorough patch/upgrade of the appropriate software and cleaned out our confirm_log tables on the lists and osu1.

Please try sending your mail again; it should trigger the challenge mail to be sent, and once we receive your response(s), previously held mail from you from the last couple of weeks should be released.

 [2006-09-09 03:40 UTC] cweldon at cerberusonline dot com
Great! What you've done has definitely fixed the problem as I am finally subscribed! Thanks a bunch!
 [2006-09-12 01:00 UTC] systems@php.net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-09-14 18:21 UTC] philip@php.net
I just tested the pear.user account and it works, closing this bug.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Dec 11 00:01:26 2023 UTC