|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29264 gettext extension loading but not working
Submitted: 2004-07-19 19:30 UTC Modified: 2004-07-30 00:28 UTC
From: borreo at softhome dot net Assigned:
Status: Closed Package: Gettext related
PHP Version: 5CVS-2004-07-19 (dev) OS: Windows 2000
Private report: No CVE-ID:
 [2004-07-19 19:30 UTC] borreo at softhome dot net
php_gettext.dll extension is not working neither on PHP 5.0 final, nor on latest CVS Win32 build:

I tried the functions bindtextdomain() and gettext() and both seem to be undefined.
The only other extension that I use, sybase_ct, works fine.

From my php.ini:
extension_dir = "c:/php/ext"

I even tried running php-cgi.exe from the command line, and I didn't receive any different error message (this really helps debugging "missing .dll" errors).

Moving around iconv.dll (e.g. copying from an old version into c:\php, see Bug #27269) didn't help either.

With PHP 4.3.7 no problem found.
Even with 5.0 RC1 no problems (provided that one manually copied the iconv.dll into c:\php).

Reproduce code:
$DomainPath = bindtextdomain( "myapp", "c:/e/webtest/inc/locale" ) ;

Expected result:
[no output expected]

Actual result:
Fatal error: Call to undefined function bindtextdomain() in C:\test.php on line 3


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-30 00:28 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 06:02:02 2015 UTC