php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27269 php_gettext.dll extension will not load
Submitted: 2004-02-15 23:51 UTC Modified: 2004-06-13 03:08 UTC
From: WPinegar at healthtech dot net Assigned: wez
Status: Closed Package: Gettext related
PHP Version: 5CVS-2004-02-18 OS: win32 only
Private report: No CVE-ID:
 [2004-02-15 23:51 UTC] WPinegar at healthtech dot net
Description:
------------
I am unable to load the php_gettext.dll extension that ships with 5.0.0b4.  When I attempt to load this extension while using the PHP ISAPI filter I get the following popup message on the server:

Warning : PHP Startup: Invalid library (maybe not a PHP library) 'php_gettext.dll' 

What do I need to do in order to get the gettext library to work in 5.0.0b4?  I had this working in PHP 4.3.x without issue so I'm just curious if in the gettext library in 5.0.0b4 is broken...

Reproduce code:
---------------
Add php_gettext.dll to the extensions in your php.ini file.

Expected result:
----------------
The gettext library should load without issue.

Actual result:
--------------
Gettext.dll library will not load.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-16 13:11 UTC] WPinegar at healthtech dot net
I've discovered the source of the issue.  php_gettext.dll is broken in 5.0.0b4.  It does not export the base DLL entry point "get_module" as required for PHP -- so it will not load.

Please correct this error in php_gettext.dll.
 [2004-02-16 22:14 UTC] sniper@php.net
Apparently the new build system for Windows broke this since it works when compiled with the old one. Assigned to Wez who broke it.. :)

 [2004-02-17 06:09 UTC] wez@php.net
next snap should work fine.
 [2004-02-18 09:58 UTC] WPinegar at healthtech dot net
With the 2/18 CVS build it looks like the php_gettext.dll library attempts to load now.  However it depends on ICONV.DLL which is not being included with the 2/18 CVS Win32 distribution.  I found a copy of the library at the URL listed below, but the PHP documentation says that the library is included with the Win32 distribution of PHP (and it has been included in prior 4.3.x releases of PHP).

Making the ICONV.DLL library available now allows the php_gettext.dll extension to load.  Thanks!

http://www.zlatkovic.com/pub/libxml/iconv-1.9.1.win32.zip
 [2004-02-18 11:29 UTC] sniper@php.net
reported problem fixed. (missing iconv is other issue)

 [2004-06-13 03:08 UTC] edink@php.net
Dependancy on ICONV.DLL has been removed (iconv is bundled with php5)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 01:01:59 2014 UTC