php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29107 Parent: child process exited with status 3221225725
Submitted: 2004-07-12 12:32 UTC Modified: 2012-10-23 07:34 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:1 (25.0%)
Same OS:2 (50.0%)
From: bart at mediawave dot nl Assigned: pajoye (profile)
Status: Closed Package: Apache2 related
PHP Version: 4.3.7 OS: Win2k
Private report: No CVE-ID: None
 [2004-07-12 12:32 UTC] bart at mediawave dot nl
Description:
------------
This bug is very similar to bug #26286. Only, in my Apache error log it says:

Parent: child process exited with status 3221225725 -- Restarting.
Parent: Created child process 2968
Child 2968: Child process is running
Child 2968: Acquired the start mutex.
Child 2968: Starting 250 worker threads.

Windows Event log:

Application popup: apache.exe - Application Error : The exception unknown software exception (0xc00000fd) occurred in the application at location 0x01a1ce13.

The problem occurs at random with UCCASS v1.04.

I'm using XAMPP on Win2k (Apache/2.0.50 (Win32) mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.7 MySQL 4.0.20a-debug-log)

It seems there's a lot of feedback at bug #26286. Maybe that status should be changed to Open?

More info: http://www.phprojekt.com/modules.php?op=modload&name=forum&file=index&kat=2&id=30946&action=writetext& 

Reproduce code:
---------------
Win2K + XAMPP + UCCASS v1.04 (I wish I could be more specific)

Expected result:
----------------
A page

Actual result:
--------------
Server hangs with Application popup: 

apache.exe - Application Error : The exception unknown software exception (0xc00000fd) occurred in the application at location 0x01a1ce13.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-23 15:34 UTC] super_freax at hotmail dot com
It says in the PHP-manual for child operations that : 

This means that for every child that opened a persistent connection will have its own open persistent connection to the server. For example, if you had 20 different child processes that ran a script that made a persistent connection to your SQL server, you'd have 20 different connections to the SQL server, one from each child. 

Note, however, that this can have some drawbacks if you are using a database with connection limits that are exceeded by persistent child connections. If your database has a limit of 16 simultaneous connections, and in the course of a busy server session, 17 child threads attempt to connect, one will not be able to. If there are bugs in your scripts which do not allow the connections to shut down (such as infinite loops), the database with only 16 connections may be rapidly swamped

======

So it might be the database that has no more connections left ? 

My Config is : 
WinXPProSP1 (NTFS Formatted)
Apache version 2.0.49 
MySQL 4.0.18 with MyODBC 3.51 and winMYSQLadmin 1.4
PHP 4.3.6 with Pear 1.3.1 ,Smarty 2.5.0 ,Zend Opt. 2.5.0 , Dbg 2.16.3, TCL 8.4.5 with TK 8.4 and Vtcl 1.6.0
 [2004-07-23 15:55 UTC] bart at mediawave dot nl
I don't think that's my problem. I'm having the problem at my testing server where, most of the time, I'm the only client. So ,if persistent connections work like they should I guess, in my case, there's only one conection there.
 [2004-08-13 05:20 UTC] loye dot young at iycc dot net
If you have the PEAR Date package installed, this may be the problem:

There is a command in a Pear function that tries to write information to the server. Some Windows installations and Unix servers with strict Safe Mode options enabled do not allow this. You can fix this yourself however. 

Open the file lib/pear/Date/TimeZone.php in a text editor. Go to line 247. You should be in a function named 'inDaylightTime()'. Add this line: return date("I"); at the very top of the function. It should now look like this: 
    function inDaylightTime($date)
    {
        return date("I");
        $env_tz = "";
        if(getenv("TZ"))
            $env_tz = getenv("TZ");
        putenv("TZ=".$this->id);
        $ltime = localtime($date->getTime(), true);
        putenv("TZ=".$env_tz);
        return $ltime['tm_isdst'];
    }

This should stop the error. Perhaps in the future, the Pear team will supply a work around. 

See if that fixes it and let everyone know.
 [2004-11-22 14:07 UTC] jorton@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2005-03-15 22:47 UTC] bart at mediawave dot nl
Argh... I can't believe that it would come as far as spamming the PHP bugs database! I'm re-opening this bug asuming somebody will want to remove the spam? If not, let me know. I'll leave them closed next time.
 [2012-10-22 21:54 UTC] nickzipse at jabico dot com
I'm getting the exact if not very similar error:

[Mon Oct 22 14:49:54 2012] [notice] Parent: child process exited with status 
3221225725 -- Restarting.
[Mon Oct 22 14:49:54 2012] [notice] Digest: generating secret for digest 
authentication ...
[Mon Oct 22 14:49:54 2012] [notice] Digest: done
[Mon Oct 22 14:49:55 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 
OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming 
normal operations
[Mon Oct 22 14:49:55 2012] [notice] Server built: Sep 10 2011 11:34:11
[Mon Oct 22 14:49:55 2012] [notice] Parent: Created child process 8448
[Mon Oct 22 14:49:56 2012] [notice] Digest: generating secret for digest 
authentication ...
[Mon Oct 22 14:49:56 2012] [notice] Digest: done
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Child process is running
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Acquired the start mutex.
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Starting 150 worker threads.
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Starting thread to listen on 
port 443.
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Starting thread to listen on 
port 443.
[Mon Oct 22 14:49:56 2012] [notice] Child 8448: Starting thread to listen on 
port 80.


This happens sporadically without any consistency of the error.
The page I try to view will randomly break and say the webserver is down.
I tried adding the return date() in the pear library but had no luck.
Any help will be much appreciated!
 [2012-10-23 07:34 UTC] pajoye@php.net
-Assigned To: +Assigned To: pajoye
 [2012-10-23 07:34 UTC] pajoye@php.net
This bug could be caused by dozen of poblems.

Please do not comment on this one but create a new one with:

- a backtrace (see https://bugs.php.net/bugs-generating-backtrace-win32.php)
- a reproduce script

Thanks for your understanding.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 00:03:34 2021 UTC