php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26101 FastCGI PHP fails as a local responder under Zeus 4.2
Submitted: 2003-11-03 17:27 UTC Modified: 2004-02-09 20:37 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:2 (50.0%)
From: david at geektech dot com Assigned: shane
Status: Closed Package: CGI/CLI related
PHP Version: 5CVS-2003-11-29 OS: FreeBSD 4.9-STABLE
Private report: No CVE-ID:
 [2003-11-03 17:27 UTC] david at geektech dot com
Description:
------------
This actually applies to 5.0.0b2, but the bug reporting system doesn't include this version.

Configure PHP with --enable-fastcgi.  Copy the sapi/cgi/php binary to %zeushome%/php/php.fcgi.

Enable PHP support in Zeus as a local responder using the easy "Enable PHP" section under "Third Party" in the web interface.

Attempt to load a PHP page.  Zeus will respond with a "502 Bad Gateway" error.  PHP 4 works fine like this.  One of the changes in PHP 5 broke it.

PHP 5 works as a FastCGI remote responder using the -b option to the PHP binary.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-29 06:37 UTC] sniper@php.net
Assigned to the maintainer.

 [2003-12-22 11:13 UTC] pmoor at netpeople dot ch
sampe problem over here, using 5.0.0b3 and apache 1.3.29.
php4, same config, worked like a charm.
 [2004-01-11 11:24 UTC] sniper@php.net
See also bug #26758

 [2004-02-09 20:37 UTC] sniper@php.net
Should be fixed in CVS now. (see bug #26758)
Reopen if the problem persists with latest CVS snapshot.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 08:02:33 2014 UTC