php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25252 CGI Application Timeout
Submitted: 2003-08-26 08:04 UTC Modified: 2004-03-30 01:26 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: brothererryn at atomicmonks dot com Assigned: phildriscoll (profile)
Status: Closed Package: CGI/CLI related
PHP Version: 4.3.3 OS: Windows 2000 Professional
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brothererryn at atomicmonks dot com
New email:
PHP Version: OS:

 

 [2003-08-26 08:04 UTC] brothererryn at atomicmonks dot com
Description:
------------
Using Windows install package, so CGI version, no extensions. Have IIS 5.0 on W2K. All PHP scripts return this error after a few minutes:

CGI Timeout
The specified CGI application exceeded the allowed time for processing. The server has deleted the process.

Even a .php file with no php code produces this error.

Reproduce code:
---------------
Example 1: 
<HTML><BODY>Test</BODY></HTML>

Example 2:
<HTML><BODY><? print "Test"; ?></BODY></HTML>

Expected result:
----------------
I expect to see "Test" displayed.

Actual result:
--------------
CGI Timeout
The specified CGI application exceeded the allowed time for processing. The server has deleted the process.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-26 15:06 UTC] dan at cognex dot com
I have this same issue.  I am trying to use phpBB.  My webhost runs fine, but they run apache on linux, whereas here I run IIS on Windows.  Please help!  :)

Exact same description as his problem.  Thanks.
 [2003-08-26 15:33 UTC] dan at cognex dot com
I downloaded this and pasted the files over my existing install.  

http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Seeming to work!

Maybe php.net should post the STABLE install on the front "downloads" page :P
 [2003-08-26 20:07 UTC] edink@php.net
It seems that the wrong binary has been shipped in the installer version of 4.3.3. Until a new package is made you can use php.exe from the zip distribution.
 [2003-08-26 20:13 UTC] edink@php.net
And I did disable the installer download for now :)
 [2003-08-27 03:14 UTC] phildriscoll@php.net
Sorry everyone - my fault. A new version of the installer 
will be available for download soon. 
 [2003-08-27 07:38 UTC] edink@php.net
Installer package has been updated with the correct php.exe.
 [2003-08-28 08:48 UTC] notepad at codewalkers dot com
i'm not sure the problem is fixed, cause i had the same problem having downloaded the installer after this conversation took place. got it working with dan's suggestion, using the stable release. you may want to double check
 [2004-01-30 01:40 UTC] evan dot swendsen at shaw dot ca
I have IIS 5.0 win Win 2K server
with php 4.3.4 (from the installer and I'm getting the same thing)  i tried pasting the 4.3.4 zip over top and im still getting it.  HELP!!
 [2004-03-29 19:26 UTC] bryan at bleu-tango dot com
I am having a similar problem with a similar setup. IIS 5, Win2k, PHP4.3.4 and 4.3.5 (tried with both). Any scripts that require database WRITES and executed with Internet Explorer (6.0) timeout. If you use Netscape, the script executes fine. If the script only does reads, you can use Netscape or IE. I have had this problem with PHPBB, in particular.

This was not an issue in PHP 4.3.2
 [2004-03-30 01:26 UTC] phildriscoll@php.net
This bug (number 25252) is related to the fact that I 
accidentally put the cli rather than the cgi version of 
php.exe into the 4.3.3 installer. This was corrected after 
a few hours, and I'm certain that I didn't repeat the 
mistake in 4.3.4 or 4.3.5. Hence, I can state with 
confidence that the problems reported after I fixed the 
original error in August 2003, are not related to this 
bug. 
 [2004-03-30 12:11 UTC] bryan at bleu-tango dot com
I have been having a similar problem, but it happens in every version from 4.3.2 through the 3-30 stable win32 release. See Bug #27781
 [2004-04-19 19:35 UTC] cdeogade at spectrum2020 dot com
hi,
I am running PHP 4.3.4.4 on IIS 5.1 on Windows XP.
I think i installed PHP in Jan 2004.
I get the folowing error message:
CGI Timeout
The specified CGI application exceeded the allowed time for processing. The server has deleted the process.

In one of your responses you stated that everything above 4.3.3 is fixed, but its doesnt seem so. Also i changed the script execution time to higher value in my IIS server.

Thanks
Chaitanya
 [2004-05-13 08:41 UTC] gvp at zzr dot dk
Yeah, i have same problem, tried different .exe's but nothing works (w2k server, IIS 5.0)
 [2004-07-28 06:45 UTC] gab_cue at hotmail dot com
The stable install seemed to work for me.....after much deliberation!!!!!!!!!

SIGH :o)
 [2004-09-05 00:14 UTC] walter at cybermight dot com
Using: Win2KSrv, IIS5, PHP4.3.8

File Upload attempt exceeding approx. 280-330 seconds:
Same (above listed) CGI error: ...exceeding allowed time for processing

Same error after attempting the following steps:
Upgrading to manual install of 4.3.8
php ini settings:

default_socket_timeout = 6000
auto_detect_line_endings = Off
safe_mode = Off
max_execution_time = 6000
max_input_time = 6000
memory_limit = 100M
post_max_size = 100M
enable_dl = Off (have tried = On)
cgi.force_redirect = 0
file_uploads = On
auto_detect_line_endings = On

IIS Application timeout is set to 60 minutes (standard 20).
IIS Connection timeoutset to 3600 (secs)

In the actual .php file consisting of the upload script I also added the line:
set_time_limit(6000);

Independent of the browser used Netscape7, Opera7.x or IE6x, and independent of the platform used to upload larger files exceeding this execution time limit, it produces this error. 

If there is a bugfix, it's certainly not completely eliminated in the 4.3.8 version, neither in the ..STABLE_VERSION listed.

Unfortunately there is no fix for this at Microsoft either, no IIS updates resolving this bug. So who actually is it that this problem needs to be addressed to?
 [2004-09-09 06:48 UTC] dan at elite-sd dot com
This is actually caused by a setting in IIS and whichever version you are using.  to correct follow these steps:In the Start Menu, go the Settings menu, and choose Control Panel.

Open the Administrative Tools control panel.

Open the Internet Services Manager item.

Right-click on the computer icon in the left panel and choose Properties from the menu that appears.

Click "Edit..." next to "WWW Services".

Click the "Home Directory" tab.

Click the "Configuration..." button.

Click the "Process Options" tab.

Enter a large value in the CGI script timeout field, perhaps 999999.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 16:01:23 2020 UTC