php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21936 since php-4.3.0 i can't configure using libmcrypt
Submitted: 2003-01-29 04:52 UTC Modified: 2003-01-29 06:03 UTC
From: mdff at a1 dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.0 OS: Solaris 8
Private report: No CVE-ID: None
 [2003-01-29 04:52 UTC] mdff at a1 dot net
hi,
i try to compile php-4.3.0 with libmcrypt 2.5.6.
i am using Sun Workshop 6 U1.

the libmcrypt was configured in 2 ways:
1st, i tried it with just ./configure. this did not work because no algorithms were included.

2nd, i tried it with:
./configure     \
--enable-static=yes     \
--with-included-algos="3-way arcfour blowfish cast-128 cast-256 des enigma gost loki97 rc2 rijndael rijndael-128 rijndael-192 rijndael-256 safer safer128 safer64 saferplus serpent tripledes twofish wake xtea"

this gave me a good version with a libmcrypt.a and a .so.

i did a make install and everything went fine. even mcrypt could be compiled and linked against the new version.

then i try to configure php with libmcrypt like this:

./configure                                     \
  --prefix=/usr/local                                           \
  --disable-cgi                                                 \
  --disable-debug                                               \
  --with-config-file-path=/usr/local/etc                        \
  --with-exec-dir                                               \
  --enable-sigchild                                             \
  --enable-magic-quotes                                         \
  --disable-rpath                                               \
  --disable-ipv6                                                \
  --with-openssl                                                \
 --disable-all                                                  \
  --with-zlib=/usr/local                                        \
  --with-crack=/usr/local                                       \
  --enable-ctype                                                \
  --with-curl=/usr/local                                        \
  --with-db3=/usr/local/BerkeleyDB.3.2                          \
  --enable-exif                                                 \
  --enable-ftp                                                  \
  --with-gd                                                     \
  --enable-gd-native-ttf                                        \
  --with-gettext=/usr/local                                     \
  --with-iconv                                                  \
  --with-imap=/usr/local                                        \
  --with-imap-ssl=/usr/local                                    \
  --with-ldap=shared,/usr/local                         \
  --enable-mbstring                                             \
  --enable-mbregex                                              \
  --with-mcrypt                                                 \
  --with-mhash=shared,/usr/local                                \
  --enable-mime-magic                                           \
  --with-mysql=/usr/local                                       \
  --with-oci8=/data/oracle                                      \
  --disable-posix                                               \
  --disable-sockets                                             \
  --enable-sysvmsg                                              \
  --enable-sysvsem                                              \
  --enable-sysvshm                                              \
  --enable-xml                                                  \
  --with-expat-dir=/usr/local                                   \
  --enable-shared                                               \
  --enable-static                                               \
  --disable-inline-optimization                                 \
  --enable-zend-multibyte


the configure script is happy until this:

checking for mcrypt support... yes
checking for mcrypt_module_open in -lmcrypt... no
checking for init_mcrypt in -lmcrypt... no
configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.


the output from config.log is:
checking for mcrypt support... yes
checking for mcrypt_module_open in -lmcrypt... no
checking for init_mcrypt in -lmcrypt... no
configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.
x:/data/a/c/php-4.3.0# tail -20 config.log
configure:41510: checking for init_mcrypt in -lmcrypt
configure:41529: cc -o conftest -xO5  -D_POSIX_PTHREAD_SEMANTICS
      -L/usr/local/lib
      -R/usr/ucblib -L/usr/ucblib -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib -R/usr/local/BerkeleyDB.3.2/lib -L/usr/local/BerkeleyDB.3.2/lib conftest.c -lmcrypt  -lcrypt -lpam -lintl -lpng -lz -ldb -lcurl -lcrack -lz -lcrypt -lssl -lcrypto -lresolv -lm -ldl -lnsl -lsocket  -lcrypt -lcurl -lz -lssl -lcrypto -ldl -lsocket -lnsl -lz 1>&5
"conftest.c", line 1: warning: 41518 is invalid in #line directive
Undefined                       first referenced
 symbol                             in file
init_mcrypt                         conftest.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 41518 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char init_mcrypt();

int main() {
init_mcrypt()
; return 0; }



now, i had some ideas and tried a few things, but the real success is missing. i don't know, whats wrong here...

is it the mcrypt-version or is it php, searching for an exported function that simply does not exist?

cu, md.

ps: this is very similar to bug #20926, but the other bug is not worked on anymore as far as i can see, and a real solution was not provided within that case...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-29 04:57 UTC] derick@php.net
Please add your comments to #20926 anyway, I just reopened it.

Derick
 [2003-01-29 05:02 UTC] mdff at a1 dot net
hi guys,

as told in bug 21936, i have similar problems with php-4.3.0 release (NOT an RC!) and libmcrypt-2.5.6.

in this case, i do not see the solution.

plz help to configure & compile,
br, md.
 [2003-01-29 06:03 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

same as #20296
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 03:01:24 2020 UTC