php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20926 libmcrypt error in configure
Submitted: 2002-12-10 17:03 UTC Modified: 2003-01-31 09:25 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: fn at panix dot com Assigned:
Status: Closed Package: mcrypt related
PHP Version: 4.3.0RC2 OS: NetBSD-1.5.2
Private report: No CVE-ID: None
 [2002-12-10 17:03 UTC] fn at panix dot com
When attempting to build php with the most recent version of libmcrypt
(available at http://mcrypt.hellug.gr/), configure produces the following 
error:
checking for mcrypt support... yes
checking for mcrypt_module_open in -lmcrypt... no
checking for init_mcrypt in -lmcrypt... no
configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.

In config.log, the errors are related to undefined references to `lt_dlerror'.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-11 10:27 UTC] derick@php.net
Which version of mcrypt do you use, and how did you configure mcrypt and PHP. I've no problems with libmcrypt 2.5.2 here.
Please also show the relevant pieces of config.log in this bugreport.

Derick
 [2002-12-11 10:52 UTC] fn at panix dot com
The configure option I used to include libmcrypt is:
--with-mcrypt=/usr/local
I am using libmcrypt-2.5.3.
The config.log entry is as follows:
configure:47349: checking for mcrypt support
configure:47388: result: yes
configure:47412: checking for mcrypt_module_open in -lmcrypt
configure:47445: gcc -o conftest -g -O2 -I/usr/local/include 
    -L/usr/local/lib -lltdl
   -L/usr/local/lib -R/usr/local/lib -L/usr/local/lib conftest.c -lmcrypt  -lpng
 -lz -ljpeg -lz -lcrypt -lssl -lcrypto -lm  -lcrypt >&5
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlclose':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:89: undefined reference
 to `lt_dlclose'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlsym':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:99: undefined reference
 to `lt_dlsym'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_close':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:112: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlopen':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:153: undefined referenc
e to `lt_dlsetsearchpath'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:155: undefined referenc
e to `lt_dlopenext'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_open':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:173: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:179: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:185: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:192: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:199: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:212: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:219: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_get_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:245: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_mode_get_size'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:264: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_set_key':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:296: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_enc_set_state'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:315: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_enc_get_state'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:333: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o):/devel/build/mcrypt/libmcrypt-2.5.3
/lib/mcrypt_modules.c:361: more undefined references to `lt_dlerror' follow
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_self_te
st':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:630: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:637: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:656: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:649: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_algorit
hm_version':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:672: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:678: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:697: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:690: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_mode_ve
rsion':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:713: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:719: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:738: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:731: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_algorithm':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:754: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:760: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:779: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:772: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_algorithm_mode':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:795: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:801: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:820: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:813: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_mode':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:836: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:842: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:861: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:854: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_block_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:877: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:883: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:902: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:895: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_key_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:918: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:924: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:943: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:936: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_supported_key_sizes':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:963: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:970: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:975: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:984: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:999: undefined referenc
e to `lt_dlexit'
collect2: ld returned 1 exit status
configure:47448: $? = 1
configure: failed program was:
#line 47419 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char mcrypt_module_open ();
#ifdef F77_DUMMY_MAIN
#  ifdef __cplusplus
     extern "C"
#  endif
   int F77_DUMMY_MAIN() { return 1; }
#endif
int
main ()
{
mcrypt_module_open ();
  ;
  return 0;
}
configure:47465: result: no
configure:47590: checking for init_mcrypt in -lmcrypt
configure:47623: gcc -o conftest -g -O2 -I/usr/local/include 
      -L/usr/local/lib
     -L/usr/local/lib -R/usr/local/lib -L/usr/local/lib conftest.c -lmcrypt  -lp
ng -lz -ljpeg -lz -lcrypt -lssl -lcrypto -lm  -lcrypt >&5
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlclose':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:89: undefined reference
 to `lt_dlclose'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlsym':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:99: undefined reference
 to `lt_dlsym'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_close':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:112: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_dlopen':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:153: undefined referenc
e to `lt_dlsetsearchpath'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:155: undefined referenc
e to `lt_dlopenext'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_open':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:173: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:179: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:185: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:192: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:199: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:212: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:219: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_get_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:245: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_mode_get_size'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:264: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_set_key':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:296: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_enc_set_state'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:315: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_enc_get_state'
:
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:333: undefined referenc
e to `lt_dlerror'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o):/devel/build/mcrypt/libmcrypt-2.5.3
/lib/mcrypt_modules.c:361: more undefined references to `lt_dlerror' follow
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_self_te
st':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:630: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:637: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:656: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:649: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_algorit
hm_version':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:672: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:678: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:697: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:690: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_mode_ve
rsion':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:713: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:719: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:738: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:731: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_algorithm':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:754: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:760: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:779: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:772: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_algorithm_mode':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:795: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:801: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:820: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:813: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_is_bloc
k_mode':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:836: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:842: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:861: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:854: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_block_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:877: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:883: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:902: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:895: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_key_size':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:918: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:924: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:943: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:936: undefined referenc
e to `lt_dlexit'
/usr/local/lib/libmcrypt.a(mcrypt_modules.o): In function `mcrypt_module_get_alg
o_supported_key_sizes':
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:963: undefined referenc
e to `lt_dlinit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:970: undefined referenc
e to `lt_dlerror'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:975: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:984: undefined referenc
e to `lt_dlexit'
/devel/build/mcrypt/libmcrypt-2.5.3/lib/mcrypt_modules.c:999: undefined referenc
e to `lt_dlexit'
collect2: ld returned 1 exit status
configure:47626: $? = 1
configure: failed program was:
#line 47597 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char init_mcrypt ();
#ifdef F77_DUMMY_MAIN
#  ifdef __cplusplus
     extern "C"
#  endif
   int F77_DUMMY_MAIN() { return 1; }
#endif
int
main ()
{
init_mcrypt ();
  ;
  return 0;
}
configure:47643: result: no
configure:47660: error: Sorry, I was not able to diagnose which libmcrypt versio
n you have installed.
 [2002-12-11 10:55 UTC] derick@php.net
Oops! Which version of libtool are you using? And did you do a "make install" of libmcrypt?

Derick
 [2002-12-11 10:59 UTC] fn at panix dot com
libtool --version
ltmain.sh (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52)

Yes, libmcrypt has been installed in /usr/local.
 [2002-12-11 11:02 UTC] derick@php.net
In order to reproduce it, I'd like to have:
1. The full configure line of libmcrypt
2. The full configure line for PHP
3. version numbers of autoconf and automake
4. version numbers of relevant libraries.

regards,
Derick
 [2002-12-11 11:14 UTC] fn at panix dot com
Please ignore the /pkg settings.  These packages get installed into /usr/local.
configure for libmcrypt:
./configure --prefix=/pkg/libmcrypt-2.5.3 --enable-shared=no --with-pic

configure for php:
./configure --prefix=/pkg/php-4.3.0rc2 --enable-shared=no --with-mysql=/pkg/mysql-3.23.46 --enable-discard-path --with-config-file-path=/pkg/php-4.3.0rc2/libdata/php-4.3.0rc2 --with-xml --with-imap-ssl=/devel/build/pine/pine-4.50/imap/ 
--libdir=/pkg/php-4.3.0rc2/libdata/php-4.3.0rc2 --with-openssl=/usr/local --with-ndbm --with-gd --with-jpeg-dir=/usr/local --with-mcrypt=/usr/local --with-zlib-dir=/usr/local --with-db

autoconf (GNU Autoconf) 2.53
automake (GNU automake) 1.4

libmcrypt-2.5.3
mysql-3.23.46
openssl-0.9.6g
gd-2.0.4
jpeg-6b
zlib-1.1.4
 [2002-12-11 11:52 UTC] derick@php.net
I believe the pkg prefix might be the problem here. Why don't  you just use "/usr/local" here?
 [2002-12-11 12:50 UTC] msopacua@php.net
The problem here is:
--enable-shared=no

in libmcrypt, but still there are lt_dl symbols in there. The lt_dl approach has never worked nicely - especially on BSD's and Derick is right, that the prefix does matter, even with --with-pic (use make DESTDIR=/pkg/libmcrypt-2.5.3 install for what I think you wanna do).

The more recent versions, allow you to link in the encryptions in the shared lib, which is the approach I would recommend.
 [2002-12-11 12:59 UTC] derick@php.net
Right, not a PHP problem -> bogus.
 [2002-12-11 13:04 UTC] fn at panix dot com
Actually, the problem is here:
--- configure~  Wed Nov 27 15:02:21 2002
+++ configure   Wed Dec 11 13:57:27 2002
@@ -47410,16 +47410,14 @@
 
 
   save_old_LDFLAGS=$LDFLAGS
-  LDFLAGS="
-    -L$MCRYPT_DIR/lib -lltdl
-   $LDFLAGS"
+  LDFLAGS="$LDFLAGS"
   echo "$as_me:$LINENO: checking for mcrypt_module_open in -lmcrypt" >&5
 echo $ECHO_N "checking for mcrypt_module_open in -lmcrypt... $ECHO_C" >&6
 if test "${ac_cv_lib_mcrypt_mcrypt_module_open+set}" = set; then
   echo $ECHO_N "(cached) $ECHO_C" >&6
 else
   ac_check_lib_save_LIBS=$LIBS
-LIBS="-lmcrypt  $LIBS"
+LIBS="-lmcrypt -lltdl  $LIBS"
 cat >conftest.$ac_ext <<_ACEOF
 #line $LINENO "configure"
 #include "confdefs.h"
 [2002-12-11 13:10 UTC] derick@php.net
hmm, :-) Patching configure is of little use, it's generated from config.m4 files. It would be nice if you could try to fix ext/mcrypt/config.m4, but I doubt it's possible.
After you modify config.m4's dont forget to rm configure && ./buildconf 

It works all fine here, so I cant really help you.

Derick
 [2003-01-02 18:45 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-01-29 05:05 UTC] mdff at a1 dot net
hi guys,

as told in bug 21936, i have similar problems with php-4.3.0 release
(NOT an RC!) and libmcrypt-2.5.6.

in this case, i do not see the solution.

plz help to configure & compile,
br, md.

ps: sorry, this comment post went to the wrong bug before...
don't know how that happened... obv. my fault ;-)
 [2003-01-29 14:56 UTC] mdff at a1 dot net
hi guys,

just in case anything goes on out there: 

I GOT IT!

short description: download libtool and install it.
this will make php-configure recognize -lmcrypt as valid.

story:
the REAL problem was not having an error while compiling mcrypt with php, it was more likely that i did not have the libtool-library libltdl.* on my system!

i downloaded libtool-1.4.3, configured it and ran a make install and THEN php was fine with libmcrypt!

the only thing i've to say is: PLEASE, if you add a -ltdl within any configure script, let the configure script CHECK FOR IT and generate ERROR messages to the user if it's not found on the system. i spent very much time (yes, my fault but....) to figure out this stuff! this would not have occurred if your configure script told me that we need ltdl to compile our stuff!


thx for support and cu,
md.

ps: you can close my bug-reports.
 [2003-01-31 09:25 UTC] msopacua@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 02:01:30 2020 UTC