php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11643 SID redefined
Submitted: 2001-06-24 13:10 UTC Modified: 2002-09-26 13:18 UTC
Votes:18
Avg. Score:4.1 ± 1.2
Reproduced:16 of 16 (100.0%)
Same Version:6 (37.5%)
Same OS:5 (31.2%)
From: zork at pablosoft dot com dot pl Assigned: hholzgra
Status: Closed Package: Session related
PHP Version: 4.3.0-dev OS: Linux
Private report: No CVE-ID:
 [2001-06-24 13:10 UTC] zork at pablosoft dot com dot pl
session_destroy() and session_register() both defines the same symbol. When I set:

error_reporting = E_ALL

in php.ini file I got warning:

Warning: Constant sid already defined in /home/sites/home/users/zork/web/report/sid.php on line 5

in this saple code:

<?
$foo = 2;
session_start();
session_destroy();
session_register("foo");
session_register("bar");
?>

On web: http://biuro.pablosoft.com.pl/~zork/report/sid.php

Zork

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-25 16:38 UTC] hholzgra@php.net
i've already noticed and fixed this, 
but my current session.c has conflicts
i ahve to resolve before checkin ...
 [2001-08-12 19:40 UTC] troels@php.net
According to http://cvs.php.net/diff.php/php4/ext/session/session.c?r1=1.213&r2=1.214&f=h&num=10, Hartmut has now succeeded in committing his session.c changes. That should mean that this bug is fixed in current CVS.
 [2001-08-12 21:01 UTC] troels@php.net
Oops. The bug is _not_ fixed yet. I misunderstood Hartmut
's comment.
 [2001-08-20 10:22 UTC] sniper@php.net
Status should be assigned..

 [2002-02-13 22:38 UTC] yohgaki@php.net
Looks like it is still there accoding to user note in the manual.

 [2002-07-03 22:36 UTC] anony at z dot com
So this has been assigned for over a year now?

This bug still exists even in 4.2.1
 [2002-07-06 19:58 UTC] sniper@php.net
Reproduced with latest CVS.


 [2002-07-24 03:10 UTC] commonwealth at commonwealth dot gov

 [2002-07-24 03:13 UTC] commonwealth at commonwealth dot gov

 [2002-07-24 03:18 UTC] commonwealth at commonwealth dot gov

 [2002-07-24 03:21 UTC] commonwealth at commonwealth dot gov

 [2002-07-24 03:24 UTC] commonwealth at commonwealth dot gov

 [2002-09-26 13:18 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 01:01:56 2014 UTC