php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9973 See below
Submitted: 2001-03-24 15:58 UTC Modified: 2001-03-25 17:58 UTC
From: rcherry at raysoft dot net Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: Earlier? Upgrade first! OS:
Private report: No CVE-ID: None
 [2001-03-24 15:58 UTC] rcherry at raysoft dot net
In an HTML form, I have created an array of check boxes with the name c[] for each box.  

I checked the third box on the form.  I expected c[0] and c[1] to be undefined, and c[2] to be "ON".  What happened was that only c[0] was defined.  A really cool approach now won't work.  

How do I work around this?

Related Topic:  How do I convince Mindspring to upgrade to PHP 4?

BTW:  Love PHP!!!

Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-25 17:58 UTC] cnewbill@php.net
This is browser-specific behavior.  IE 5 will not send the other two, because they have no value and it would be inefficient to do so.  Same with Netscape 6, don't have that crud Netscape 4 around to test. So, c[2] is actually c[0] because the other two don't exist.

If you want them in a specific order you should hardcode the indexes.  c[0], c[1], c[2], etc.

As for Mindspring, gripe, gripe, gripe.  It still probably won't get you anywhere.

-Chris
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC