php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9880 Apache Core dumps when trying to execute. No compilation errors.
Submitted: 2001-03-20 14:44 UTC Modified: 2001-04-19 10:23 UTC
From: jason dot gulledge at alltel dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.4pl1 OS: SunOS 5.7 Generic_106541-11 sun4
Private report: No CVE-ID: None
 [2001-03-20 14:44 UTC] jason dot gulledge at alltel dot com
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "sparc-sun-solaris2.7"...(no debugging symbols found)...
Core was generated by `/usr/local/apache/bin/httpd'.
Program terminated with signal 11, Segmentation Fault.
Reading symbols from /usr/lib/libpam.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libpam.so.1
Reading symbols from /usr/lib/libdl.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libdl.so.1
Reading symbols from /usr/lib/libsched.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libsched.so.1
Reading symbols from /usr/lib/libgen.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgen.so.1
Reading symbols from /usr/lib/libsocket.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libsocket.so.1
Reading symbols from /usr/lib/libnsl.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libnsl.so.1
Reading symbols from /usr/lib/libresolv.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libresolv.so.2
Reading symbols from /usr/lib/libm.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libm.so.1
Reading symbols from /usr/lib/libcrypt_i.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcrypt_i.so.1
Reading symbols from /app/oracle/product/8.1.6/lib/libclntsh.so.8.0...(no debugging symbols found)...done.
Loaded symbols for /app/oracle/product/8.1.6/lib/libclntsh.so.8.0
Reading symbols from /usr/lib/libc.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libc.so.1
Reading symbols from /usr/lib/libmp.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libmp.so.2
Reading symbols from /app/oracle/product/8.1.6/lib/libwtc8.so...(no debugging symbols found)...done.
Loaded symbols for /app/oracle/product/8.1.6/lib/libwtc8.so
Reading symbols from /usr/lib/libaio.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libaio.so.1
Reading symbols from /usr/platform/SUNW,Ultra-Enterprise-10000/lib/libc_psr.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/platform/SUNW,Ultra-Enterprise-10000/lib/libc_psr.so.1
Reading symbols from /usr/lib/nss_files.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/nss_files.so.1
#0  0xff0b6dec in strlen () from /usr/lib/libc.so.1

(gdb) run -X
Starting program: /usr/local/apache/bin/httpd -X
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0xff0b6dec in strlen () from /usr/lib/libc.so.1
(gdb) bt
#0  0xff0b6dec in strlen () from /usr/lib/libc.so.1
#1  0xb3be0 in zend_register_functions ()
#2  0xb402c in zend_register_internal_class ()
#3  0x44260 in php_minit_oci ()
#4  0xb3b18 in zend_startup_module ()
#5  0x2dbc4 in php_startup_extensions ()
#6  0x2ec64 in php_startup_internal_extensions ()
#7  0x2ded0 in php_module_startup ()
#8  0x2af8c in sapi_apache_send_headers ()
#9  0x2bfc0 in php_init_handler ()
#10 0x11bd10 in ap_init_modules ()
#11 0x12a5e4 in main ()


This is the output.  When trying to execute "apachectl start" it immediately core dumps.

Jason

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-21 14:37 UTC] sniper@php.net
Could you please try the latest CVS snapshot from http://snaps.php.net/ and add --enable-debug to your configure line to get useful backtrace.

--Jani

 [2001-04-19 09:41 UTC] sniper@php.net
Have you tried with latest CVS snapshot yet?

--Jani

 [2001-04-19 10:23 UTC] derick@php.net
User reported that is was fixed with a make clean
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 07:05:44 2022 UTC