php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9828 LDAP: Object class violation
Submitted: 2001-03-18 21:46 UTC Modified: 2001-03-29 00:44 UTC
From: kcchung at school dot net dot hk Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.0.4pl1 OS: Solaris 7
Private report: No CVE-ID: None
 [2001-03-18 21:46 UTC] kcchung at school dot net dot hk
when using php-4.0.3, ldap_add function works very well.
After upgrading to php-4.0.4pl1, ldap_add function
didn't work again. A error occured and logged in apache
error log, "LDAP: Object class violation".

php config
'./configure' '--with-config-file-path=/usr/slocal/etc' '--with-apxs=/usr/slocal/apache-1.3.19/bin/apxs' '--with-ldap=/usr/local' '--with-mysql=/usr/slocal/mysql' '--without-gd' '--with-mcrypt'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-26 17:56 UTC] sniper@php.net
Did you update your ldap libraries also?
And does the same add work using the command line tools?

--Jani

 [2001-03-26 20:38 UTC] kcchung at school dot net dot hk
The ldap server I am using is openldap 1.2.11 which is the
current stable version. ldapadd works in command line.

The most strange thing is php 4.0.3pl1 works for me but
php 4.0.4pl1 doesn't. So I suspect the change from 4.0.3pl1
to 4.o.4pl1 has something wrong with ldap functions.

--George Chung
 [2001-03-27 04:07 UTC] sniper@php.net
1. Please add the shortest possible script to reproduce this
problem into this bug report
2. Check that the libphp4.so really is linked with the correct ldap libraries: 'ldd libphp4.so'

--Jani

 [2001-03-29 00:44 UTC] kcchung at school dot net dot hk
The problem is found.

I found that there are some changes in ldap functions in
php 4.0.4pl1. the ldap_get_entries changed in php 4.0.4pl1.
It returns an array if there is no entry which is not expected
in my code. It makes my code stop working since php 4.0.4pl1.

I suspect this sudden change will make a lot of codes stop
working.

Anyway, thank you very much for you help.

--George Chung
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 14:03:43 2023 UTC