php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #979 [PEAR] Openmarket Transact support
Submitted: 1998-12-07 18:56 UTC Modified: 2006-12-12 12:36 UTC
From: graeme at kc dot co dot nz Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0 OS: N/A
Private report: No CVE-ID: None
 [1998-12-07 18:56 UTC] graeme at kc dot co dot nz
Any chance of support for OpenMarket Transact in PHP. I can't code so I'm just fantasising. Maybe someone will pick it up someday.
A full SDK is available from OpenMarket (www.openmarket.com).

Transact is amongst other things, a secure way of processing transactions. DOs (digital offers) and DCs (digital coupons) can be produced according so a certain encoding process that is then passed to the Transact server for processing.
This means you can provide products and services using these items independent of the ISP and they can be attached to any URl, anywhere.

It wouild be real nice to be able to produce a DO from a DB using PHP for passing to Transact.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 12:35 UTC] jimw@php.net
doesn't look like anybody has written an openmarket transact extension. refiled against 4.0.
 [2001-02-10 14:23 UTC] jimw@php.net
whoops, really refiled this time.
 [2002-02-24 06:54 UTC] sander@php.net
OpenMarket seems to be gone.
 [2002-02-26 10:41 UTC] mrobinso@php.net
OpenMarket is still there. Reopening, as this is
a valid feature request for PEAR.
 [2006-12-12 12:36 UTC] pajoye@php.net
Please use the PEAR bug system.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC