php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9735 Mysql / IMAP issues
Submitted: 2001-03-13 22:04 UTC Modified: 2001-03-15 22:20 UTC
From: danellis at rushmore dot com Assigned:
Status: Closed Package: MySQL related
PHP Version: 4.0.4pl1 OS: LInux Redhat 7
Private report: No CVE-ID: None
 [2001-03-13 22:04 UTC] danellis at rushmore dot com
WHen using imap and mysql modules together, the imap will fail with a "Unable to find stream error" anytime that the imap_open is called after a mysql_connect call.  I am using rpms, all same version.  If oyu put the imap calls beore the ysql_connect, no problem, just in that psecific order.  I can send specific code if needed.

Dan Ellis

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-13 22:34 UTC] sniper@php.net
Please attach short as possible example script 
into this bug report.

--Jani

 [2001-03-14 18:37 UTC] danellis at rushmore dot com
I will try to attach a script soon.  The problem does not seem to happen when a smaller script (20 or so lines) runs, but does when larger ones run (~100 lines).  The imap server see's no traffic (tcpdump, which makes sense).  I am trying to match it specifically down to a situation, but have noticedthe issue with four different scripts I have created.  I have switched to a homegrown fsocket approach in the meantime.  I can attach the scripts I am having issues with, if needed.  By simply switching the mysql_dbconnect and the imap_open()/imap_createmailbox() calls, the problem occurs and doesn't occur.
 [2001-03-14 18:51 UTC] danellis at rushmore dot com
I will try to attach a script soon.  The problem does not seem to happen when a smaller script (20 or so lines) runs, but does when larger ones run (~100 lines).  The imap server see's no traffic (tcpdump, which makes sense).  I am trying to match it specifically down to a situation, but have noticedthe issue with four different scripts I have created.  I have switched to a homegrown fsocket approach in the meantime.  I can attach the scripts I am having issues with, if needed.  By simply switching the mysql_dbconnect and the imap_open()/imap_createmailbox() calls, the problem occurs and doesn't occur.
 [2001-03-15 22:04 UTC] sniper@php.net
Please check bug report: #7816
which describes this same problem. You're propably 
having that same error in your script.

--Jani

 [2001-03-15 22:20 UTC] danellis at rushmore dot com
Solution presented in Bug 7816

Thanks.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 11:01:25 2019 UTC