php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9729 --enable-sockets problem
Submitted: 2001-03-13 19:34 UTC Modified: 2001-04-10 11:47 UTC
From: xue dot mei dot tang at openwave dot com Assigned: jason (profile)
Status: Closed Package: Installation problem
PHP Version: 4.0.4pl1 OS: Solaris2.8
Private report: No CVE-ID: None
 [2001-03-13 19:34 UTC] xue dot mei dot tang at openwave dot com
I tried to configure the php-4.0.4pl1 with options "--enable-sockets" under
Solaris 2.8.

The commands that I typed in are shown next.

/export/xmtang/php-4.0.4pl1>./configure --prefix="/export/xmtang/php" --with
-apache=../apache_1.3.14 --enable-sockets
/export/xmtang/php-4.0.4pl1>make

Then I got  some errors.

make[3]: Entering directory `/export/xmtang/php-4.0.4pl1/ext/sockets'
gcc  -I. -I/export/xmtang/php-4.0.4pl1/ext/sockets -I/export/xmtang/php-4.0.
4pl1
/main -I/export/xmtang/php-4.0.4pl1 -I/export/xmtang/apache_1.3.14/src/inclu
de -
I/export/xmtang/apache_1.3.14/src/os/unix -I/export/xmtang/php-4.0.4pl1/Zend
 -I/
export/xmtang/php-4.0.4pl1/ext/mysql/libmysql -I/export/xmtang/php-4.0.4pl1/
ext/
xml/expat/xmltok -I/export/xmtang/php-4.0.4pl1/ext/xml/expat/xmlparse -I/exp
ort/
xmtang/php-4.0.4pl1/TSRM  -D_POSIX_PTHREAD_SEMANTICS -DXML_BYTE_ORDER=21 -g
-O2
 -c sockets.c && touch sockets.lo
sockets.c: In function `php_if_recvmsg':
sockets.c:1728: structure has no member named `msg_control'
sockets.c:1729: structure has no member named `msg_controllen'
sockets.c:1731: structure has no member named `msg_control'
sockets.c:1732: structure has no member named `msg_controllen'
sockets.c:1735: structure has no member named `msg_flags'
sockets.c:1741: structure has no member named `msg_control'
sockets.c:1750: warning: passing arg 3 of `add_assoc_string' makes pointer
from
integer without a cast
sockets.c:1754: structure has no member named `msg_controllen'
sockets.c:1755: structure has no member named `msg_flags'
sockets.c:1787: structure has no member named `msg_control'
sockets.c:1788: structure has no member named `msg_controllen'
sockets.c:1790: structure has no member named `msg_control'
sockets.c:1791: structure has no member named `msg_controllen'
sockets.c:1794: structure has no member named `msg_flags'
sockets.c:1800: structure has no member named `msg_control'
sockets.c:1810: warning: passing arg 3 of `add_assoc_string' makes pointer
from
integer without a cast
sockets.c:1812: structure has no member named `msg_controllen'
sockets.c:1814: structure has no member named `msg_flags'
make[3]: *** [sockets.lo] Error 1
make[3]: Leaving directory `/export/xmtang/php-4.0.4pl1/ext/sockets'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/export/xmtang/php-4.0.4pl1/ext/sockets'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/xmtang/php-4.0.4pl1/ext'
make: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-13 22:29 UTC] sniper@php.net
Please get the latest CVS snapshot from http://snaps.php.net/ and try the solution mentioned
in #8667 (last comment)

--Jani


 [2001-03-14 16:16 UTC] xue dot mei dot tang at openwave dot com
I have downloaded the latest version PHP4 (3/13/2001)followed the ticket #8667(last comment). It did solve the problem that I metioned before. 

I have wrote a simple php program to test the socket() function. The code is shown next.

$socket = socket (AF_INET, SOCK_STREAM, 0);  
if ($socket < 0) {
    echo "socket() failed: reason: " . strerror ($socket) . "\n";
} else {
    "socket() successful: " . strerror ($socket) . "\n";
}   

But it causes proble: Fatal error: Call to undefined function: socket()

I have checked the php.ini. It shows sockets.use_system_read=On.

Do you know how to solve this problem?

Thanks
 [2001-04-04 01:42 UTC] jason@php.net
I looked into this, and I know what the problem is , I will
have a workaround shortly, provided all tests pass.

-jason
	
 [2001-04-10 11:47 UTC] jason@php.net
Fixed In CVS: See comment on ( sockets.c,v 1.34 )

-Jason
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 05:05:45 2022 UTC