php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #972 *Document contains no data* received after a lot of loops
Submitted: 1998-12-04 15:17 UTC Modified: 1999-11-28 17:42 UTC
From: arneodo at initiative dot fr Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0.5 OS: Linux RedHat 5.1
Private report: No CVE-ID: None
 [1998-12-04 15:17 UTC] arneodo at initiative dot fr
// Increase $loop if you don't receive "Document contains no data"
// this seems to work on NT4 but not on RedHat

function f1($s){
  $a = $s;
  return $a;
}
function f2($s){
  $a = $s;
  return $a;
}
function f3($s){
  $a = $s;
  return $a;
}

function run($s, $h1, $h2, $h3){
  $loop = 1000000;
  for( $i = $loop ; $i > 0 ; $i-- ) {
    $h1( (string) $i );
    $h2( (string) $i );
    $h3( (string) $i );
  }
}

run( "test", 'f1', 'f2', 'f3' );
echo "Test is OK";

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-28 17:42 UTC] rasmus at cvs dot php dot net
Please resubmit if you can still reproduce this bug.  I can't reproduce it here.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 15 20:01:28 2019 UTC