php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9688 FTP_PUT / FOPEN
Submitted: 2001-03-11 17:49 UTC Modified: 2002-02-02 06:42 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: ivarness at yahoo dot no Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.0.4 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2001-03-11 17:49 UTC] ivarness at yahoo dot no
I'm working against a IIS web server with PHP 4.0.4
It seems that both ftp_up and fopen causes the same
problem, not allowing you to upload files.
On the attempt to open sourcefile/submited file 
I get following errors;

with ftp_up:
Warning: error opening G:\\mysite\\mysite\\gfx\\icon_editor_url.gif in ftp.php on line 19

with fopen:
Warning: fopen("G:\\mysite\\mysite\\gfx\\icon_editor_list.gif","rb") - No such file or directory in uploadfile.php on line 7

hence under linux, I have tested the fopen with php4.0.b3
and it seems to work. Question me for samplecode if needed.

Regards,
IN.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-18 04:30 UTC] jmoore@php.net
The problem here seems that PHP cant access the drive or file. Have you checked permissions? Is G:\ a mapped network drive? Is the path correct?? Please check these, then try latest CVS (snapshots for win32 are avalible here: http://www.zend.com/snapshots )

- James
 [2001-05-21 00:32 UTC] ivarness at yahoo dot no
It might be for all I know , a permission problem which occure when


one are using maped network drives/virtual hosts under IIS. I can't say either

as I was using a remote host(or web hoster). 


If it's the case it shouldn't be fixed anyway??


I think it's a bit scame cause if your working on a huge project and


you can't upload file where the point of using it all??


Anyway people have been asking for work arounds, I can't say


I know of a work around which guarantees success , but I made


a script to test file-uploades with different approaches


(ftp_functions,  fopen("ftp://....") , copy())  


Main purpose of this was cause I found myself in a postion


where I needed to change web-hoster because of this bug,


(fortunately I'm not paying for this service) and I wanted to know


if next web-hoster would have same problem.


The test script can be found at http://www.valar.f2s.com , hope it helps!


Meanwhile lets hope for a bug fix!!?


--



Best Regards,
IN

 [2002-01-12 06:58 UTC] lobbin@php.net
Can you try out 4.1.1 and see if the problem still exists?
 [2002-02-02 06:42 UTC] sander@php.net
No feedback was provided for this bug, so it is being suspended.
If you are able to provide the information that was requested,
please do so and change the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 07:03:37 2021 UTC