php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9687 x-httpd-source fails with zero length
Submitted: 2001-03-11 17:22 UTC Modified: 2001-06-27 22:36 UTC
From: markhers at green-ant dot com Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0 Latest CVS (11/03/2001) OS: RedHat 7.0
Private report: No CVE-ID: None
 [2001-03-11 17:22 UTC] markhers at green-ant dot com
For a while, I have been experiencing an irksome problem since about 4.0.4, but I can't pinpoint when exactly it started.

On RedHat 7.0, I have the following webserver running:

Apache/1.3.19 (Unix) PHP/4.0.5-dev mod_ssl/2.8.1 OpenSSL/0.9.5a

on a 500 Mhz P3 with 240 MB of RAM.

The PHP DSO module is built from the CVS pull from about 12pm PDT today (3/11/2001).

Anyway, whenever I try to access a pretty colored source code version of any of my files via .phps (where .phps is one of the extensions setup as an application/x-httpd-source type), I get a "zero data" message from my browser.

The physical configruation line shows:

AddType application/x-httpd-php-source .phps .inc

I compiled PHP as a CGI version to see if it was an Apache issue, and the same thing happens.

The Apache child processes aren't dying, either. And the logs show a content legth of 0 and a successful request, so i don't have any idea what's really going on.

I'm willing to assist anyone in determining the cause of the problem, but I haven't seen it listed anywhere else.

I have the following PHP configuration:

'./configure' '--with-apxs=/opt/apache/sbin/apxs' '--enable-track-vars' '--enable-inline-optimizations' '--enable-trans-sid' '--with-mysql' '--with-pgsql=/usr/local/pgsql' '--with-curl=/usr/local/curl' '--with-gd' '--with-t1lib-dir=/usr/local/t1lib' '--with-ttf' '--enable-pcre' '--with-bz2=/usr/local/bzip2' '--with-zlib' '--with-zlib-dir=/usr' '--enable-wddx' '--with-dom=/usr/local/libxml'

Any help or pointers to provide more help is welcome.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-14 13:44 UTC] markhers at green-ant dot com
I must be missing something, but it would seem your 
suggestion/solution is to symlink all my files for which I 
want to see coloring to different file extensions to see 
their source.

For curiosity's sake, I tried this, but it as well didn't 
work.

The issue is not mistaken file extension association, or 
misspelled directives, so I can only assume it's either 
related to Apache when it tries to retrieve the data from 
PHP after an application/x-httpd-php-source directive, or 
related to the application/x-httpd-php-source directive 
handler in PHP itself. Either way, I'd like to track it 
down. What should I do?
 [2001-03-14 15:33 UTC] sniper@php.net
Try changing the httpd.conf directives to:

AddType application/x-httpd-php .php .inc
AddType application/x-httpd-php-source .phps .incs

--Jani

p.s. Fancy coloring works for me just fine..
I guess you know that you have to copy (or link) the
original file to that extension to get it colored?




 [2001-06-05 02:35 UTC] sniper@php.net
Does this work with PHP 4.0.6RC2:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

--Jani

 [2001-06-27 22:36 UTC] sniper@php.net
No feedback, works for me fine with 4.0.5 - 4.0.7-dev


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 02:01:27 2019 UTC