php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9678 multipart/form POSTS corrupted
Submitted: 2001-03-11 00:11 UTC Modified: 2001-03-11 16:30 UTC
From: carl at maiatech dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.0.4pl1 OS: redhat 7.0
Private report: No CVE-ID: None
 [2001-03-11 00:11 UTC] carl at maiatech dot com
Ever since 4.0.4pl1, any fields posted with a form using enctype=multipart/form are currupted.

One or two line feed seem to be added to text fields when the come as variables in the receiving PHP script.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-11 00:14 UTC] sniper@php.net
Submitted twice. (#9677)

 [2001-03-11 07:23 UTC] carl at maiatech dot com
This is NOT submitted twice.

This is similar (and maybe related) to a bug I reported where file uploads (which have to use multipart/form) are corrupted. But this is DIFFERENT.

This bug refers to the corruption of simple text-fields in the POST as well.

Text fields have line returns added to them, so that for example a field submitted with contents "picturename.jpg" winds up as "\n\npicturename.jpg" when it becomes a variable
 [2001-03-11 16:30 UTC] sniper@php.net
It's the same bug. And it's fixed. Please try the 
latest CVS snapshot from http://snaps.php.net/

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 06:01:26 2019 UTC