php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9661 PHP sometimes dumps core
Submitted: 2001-03-09 13:34 UTC Modified: 2001-03-17 12:46 UTC
From: michael at carceri dot dk Assigned:
Status: Not a bug Package: Reproducible Crash
PHP Version: 4.0 Latest CVS (09/03/2001) OS: Linux 2.4.1
Private report: No CVE-ID: None
 [2001-03-09 13:34 UTC] michael at carceri dot dk
When I run .php files under Apache (1.3.19) PHP sometimes crash. I can run the same file several times, and only sometimes is crashes PHP. I have found out that it only happens when the PHP file is accessing a MySQL database.

This is what is recorded in the apache log (a lot of them):

[Fri Mar  9 19:24:51 2001] [notice] child pid 22845 exit signal Segmentation fault (11)

I have generated a backtrace (sorry, apache is not compiled with debug information - only PHP):

Starting program: /usr/local/apache/bin/httpd -f /usr/local/apache/conf/httpd.conf -X
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x400da4c1 in free () from /lib/libc.so.6
(gdb) bt
#0  0x400da4c1 in free () from /lib/libc.so.6
#1  0x400da343 in free () from /lib/libc.so.6
#2  0x401982cc in shutdown_memory_manager (silent=1, clean_cache=0)
    at zend_alloc.c:478
#3  0x401c1845 in php_request_shutdown (dummy=0x0) at main.c:665
#4  0x401bf26b in php_apache_request_shutdown (dummy=0x0) at mod_php4.c:290
#5  0x8095d19 in run_cleanups ()
#6  0x80943a5 in ap_clear_pool ()
#7  0x8094427 in ap_destroy_pool ()
#8  0x80a4fc3 in child_main ()
#9  0x80a5141 in make_child ()
#10 0x80a52bc in startup_children ()
#11 0x80a592c in standalone_main ()
#12 0x80a617c in main ()
#13 0x40086dcc in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-09 18:44 UTC] sniper@php.net
What was the configure line used for PHP 4 ?

--Jani

 [2001-03-09 18:50 UTC] michael at carceri dot dk
Sorry, I forgot the configure line. It's:

--enable-track-vars --with-mysql=/usr/local/mysql --with-mhash --with-mcrypt --with-apxs=/usr/local/apache/bin/apxs
 [2001-03-10 19:58 UTC] sniper@php.net
What is the mysql version you are using?
And have you tried the latest CVS snapshot from http://snaps.php.net/ as I can't reproduce this with
latest CVS.

--Jani

 [2001-03-10 19:59 UTC] sniper@php.net
ehm..sorry, I just noticed that you had tried with
latest CVS. Or have you? Could you please try and update
your checkout?

--Jani

 [2001-03-10 21:08 UTC] michael at carceri dot dk
I have tried with the CVS snapshot from 09/03/2001, but can try with a newer snapshot if you need it.

I use MySQL version 3.22
 [2001-03-16 20:20 UTC] sniper@php.net
Please add a shortest possible script into this bug report, which can be used to reproduce this.

--Jani

 [2001-03-16 21:00 UTC] michael at carceri dot dk
Sorry, this problem is not MySQL related after all. It's caused by calls to mcrypt functions used in my database php file. I have created a new bug report under "mcrypt related". Please close this one.
 [2001-03-17 12:46 UTC] sniper@php.net
Closed per user request.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 18:01:27 2019 UTC