php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9500 mssql_query returns false for INSERT & UPDATE queries
Submitted: 2001-02-28 16:05 UTC Modified: 2002-06-18 18:24 UTC
From: gsohl at freedomgroup dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.4pl1 OS: NT 4.0
Private report: No CVE-ID: None
 [2001-02-28 16:05 UTC] gsohl at freedomgroup dot com
<?php
mssql_connect('myserver', 'user', 'password');
mssql_select_db('mydatabase');

$Result = mssql_query("UPDATE mytable SET nextval=nextval+1");
if ($Result)
	{
	echo("Result is TRUE<BR>");
	}
else
	{
	echo("Result is FALSE<BR>");
	}

echo '<BR><BR>';

$Result = mssql_query("INSERT mytable values(10)");
if ($Result)
	{
	echo("Result is TRUE<BR>");
	}
else
	{
	echo("Result is FALSE<BR>");
	}
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-08 18:56 UTC] sniper@php.net
Mind telling that which bug report is the duplicate
to this one?

--Jani

 [2001-03-09 13:27 UTC] sniper@php.net
Duplicate of #8777

 [2002-06-18 18:24 UTC] sniper@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Apr 02 12:03:38 2023 UTC