php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9485 Missing libsasl.dll
Submitted: 2001-02-27 12:06 UTC Modified: 2001-04-27 13:38 UTC
From: declosmadeuce at logica dot com Assigned:
Status: Not a bug Package: LDAP related
PHP Version: 4.0.4pl1 OS: Windows NT 4 SP5
Private report: No CVE-ID:
 [2001-02-27 12:06 UTC] declosmadeuce at logica dot com
PHP4 Win32 binaries distribution contains a dll called "php_ldap.dll", but it needs a missing dll called "libsasl.dll"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-27 13:38 UTC] dbeu@php.net
nope it doesn't
 [2002-03-27 13:42 UTC] leedan at hotmail dot com
I think this may be related to Bug #14464 - depends.exe reports both LIBSASL.DLL and APPHELP.DLL as dependencies for php_ldap.dll. However, as noted in 14464, this appears to be a problem with machines running IE6. Note that most extensions fail in this situation, not just php_ldap.dll.
 [2003-06-24 04:30 UTC] joris dot lambrecht at pandora dot be
The whole php_ldap.dll issue with Win2k/IIS5 is mostly bizar. Copying the dlls/*.dll files to the suggested directory (winnt\system32) did not resolve a thing. So i copied to (\winnt\system32\dllcache) as well, got a fit when even this did not resolve anything. Then edited php.ini with some wet-finger touch and see, it works very nicely by now.

Any well documented Knowledgebase article on this issue would be most welcome since there are a lot of naah, this is not what you're supposed to do postings but no clearly documentation on what's going on, what to do, what to test etc.

Anyway, it's working now, i'm happy.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 12:02:07 2014 UTC