php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9457 cannot compile with native Solaris libldap (fix included)
Submitted: 2001-02-26 07:28 UTC Modified: 2001-04-01 14:05 UTC
From: tsv at ot dot ru Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.0.4pl1 OS: Solaris 8 (Sparc)
Private report: No CVE-ID: None
 [2001-02-26 07:28 UTC] tsv at ot dot ru
./configure --with-ldap ...
don't use native /usr/lib/libldap.so

*** ext/ldap/config.m4  Mon Feb 26 15:16:51 2001
--- ext/ldap/config.m4.orig     Mon Feb 26 15:16:01 2001
***************
*** 43,50 ****
        if test -f $LDAP_LIBDIR/liblber.a -o -f $LDAP_LIBDIR/liblber.so ; then
                AC_ADD_LIBRARY_WITH_PATH(lber, $LDAP_LIBDIR, LDAP_SHARED_LIBADD)
                AC_ADD_LIBRARY_WITH_PATH(ldap, $LDAP_LIBDIR, LDAP_SHARED_LIBADD)
-       elif test -f $LDAP_LIBDIR/libldap.so ; then
-               AC_ADD_LIBRARY_WITH_PATH(ldap, $LDAP_LIBDIR, LDAP_SHARED_LIBADD)
        elif test -f $LDAP_LIBDIR/libldapssl41.so; then
                if test -n "$LDAP_PTHREAD"; then
                        AC_ADD_LIBRARY($LDAP_PTHREAD)
--- 43,48 ----


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-01 14:05 UTC] sniper@php.net
This should be fixed in CVS now. Please try the latest snapshot from http://snaps.php.net/

Reopen this bug report if it doesn't work.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 17:05:51 2022 UTC