php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9446 CGI version echos first line
Submitted: 2001-02-25 15:37 UTC Modified: 2001-03-06 12:07 UTC
From: vinay at kryogen dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
 [2001-02-25 15:37 UTC] vinay at kryogen dot com
using PHP 4.0.4pl1 under Linux

I configured php as:
./configure --with-mysql=/usr/local/mysql --with-pgsql=/usr/local/posgresql --enable-track-vars --enable-gd=../gd1.8.3 --enable-ftp --enable-discard-path

now.. the problem is simple... i create script to run from the shell containing the following:

#!/usr/local/bin/php
<?
	echo "asdf";
?>

the problem: PHP prints #!/usr/local/bin/php on top of all output.. i tried to use output buffering to suppress it, but it doesnt catch it, without the #!/usr/local/bin/php I cant run the script from shell properly ... 

I noticed this issue since version 4.0.3pl1 (I think) .. but it was not existant in past versions (4.0.2 ,  etc)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-06 06:34 UTC] stas@php.net
Do you use Zend Optimizer, probably?
 [2001-03-06 11:52 UTC] vinay at kryogen dot com
Yes, I use Zend Optimizer.  Is it causing the problem ?
 [2001-03-06 11:59 UTC] stas@php.net
Putting this:

zend_optimizer.enable_loader=0

in the php.ini should help you.
 [2001-03-06 12:07 UTC] vinay at kryogen dot com
there are encoded files on that machine too.  By disabling optimizer, all encoded files stop running.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 13:01:28 2024 UTC