php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9435 Unreproducable crash of PHP
Submitted: 2001-02-24 08:18 UTC Modified: 2001-06-19 01:29 UTC
From: tilliw at tdonline dot net Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4pl1 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-02-24 08:18 UTC] tilliw at tdonline dot net
After some time of browsing a PHP website (access to an oracle DB not on the same machine) PHP crashes:

PHP has encountered an Access Violation at 011A2466

Event-Log entry (sorry, german):

Ereignistyp:	Fehler (error, type)
Ereignisquelle:	WAM (source)
Ereigniskategorie:	Keine (category "None")
Ereigniskennung:	204 (event-id)
Datum:		24.02.2001 (date)
Zeit:		11:03:45 (time)
Benutzer:		Nicht zutreffend (user)
Computer:	AD-OPAS1 (computer)
Beschreibung: (description)
Der HTTP-Server ist bei der Verarbeitung der ISAPI-Anwendung '
php4ts!zend_strndup + 0x2B
 + 0xA05F69B8
' auf eine unerwartete Ausnahme gesto?en. (unexpected exception in isapi-application)


I can continue surfing after the corresponding dllhost.exe is terminated using the task manager, or the iis-admin service is restarted.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-26 14:13 UTC] jmoore@php.net
could you translate the errors please.

- James
 [2001-06-01 13:36 UTC] jmoore@php.net
does this occur after a specific amount of requests?

- James
 [2001-06-18 20:25 UTC] sniper@php.net
No feedback.

 [2001-06-19 01:29 UTC] tilliw at tdonline dot net
Well, it occurs randomly. Seems though that it takes longer to crash if the site is being surfed frequently. In other words, if just a couple of pages are viewed, then after a couple minutes another one, the chance is pretty good that PHP just crashed. I think it has something to do with the oci8 functions being called.

We moved the site to a linux version of php and there it worked without changes.
 [2002-05-02 03:22 UTC] stefan at digiconcept dot net
ok, Win2K, IIS5, PHP 4.1.2. Same error as described in the upper messages. PHP craches after an undefinalbe amout of request. it simply dies, that's it. we use odbc, not oci. same result. for me, it seems to be a problem of the zend-engine within a win2k environment.
soory, i cant provide any more infos because the "stange error" is as diffus as described.
hint : php may also crash if you call a simple "hello world" without using any extensions.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 04:05:52 2022 UTC