php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9341 "php -l file.php" seg faults, dumps core
Submitted: 2001-02-19 14:31 UTC Modified: 2001-02-22 18:38 UTC
From: colin at easydns dot com Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 4.0 Latest CVS (19/02/2001) OS: RH7.0
Private report: No CVE-ID: None
 [2001-02-19 14:31 UTC] colin at easydns dot com
Running the CGI version, if you do a "php -l file.php" (i.e. the "lint" option) on a file that has syntax errors, PHP doesn't report anything but segfaults and dumps core.

Backtrace reveals:

#0  destroy_op_array (op_array=0x0) at zend_opcode.c:144
#1  0x8066072 in php_lint_script (file=0xbffffa60) at main.c:1236
#2  0x8064748 in main (argc=3, argv=0xbffffb04) at cgi_main.c:739
#3  0x4026ab5c in __libc_start_main (main=0x8063fc4 <main>, argc=3, ubp_av=0xbffffb04, init=0x8061b74 <_init>, 
    fini=0x810cc3c <_fini>, rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffafc)
    at ../sysdeps/generic/libc-start.c:129

My config line:

./configure \
--with-mysql=/usr/local \
--disable-pear \
--enable-track-vars \
--disable-debug \
--disable-magic-quotes \
--enable-ftp \
--with-gettext \
--with-xml \
--with-dom \
--enable-wddx \
--with-curl \
--with-pgsql \
--with-zlib \
--enable-versioning \
--enable-sockets \
--with-openssl \
--with-snmp \
--with-mcrypt

- Colin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-20 06:08 UTC] sniper@php.net
Duplicate of #9311
 [2001-02-22 18:38 UTC] sniper@php.net
Fixed in CVS now.

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 15:01:25 2019 UTC