php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9318 Lots of ORA-24324 warning in apache error_log
Submitted: 2001-02-17 09:21 UTC Modified: 2001-04-10 10:03 UTC
From: erol at infotron dot com dot tr Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.3pl1 OS: RH 6.2 Linux kernel 2.2.16-3
Private report: No CVE-ID: None
 [2001-02-17 09:21 UTC] erol at infotron dot com dot tr
 There are lots of

<b>Warning</b>:  failed to rollback outstanding transactions!: ORA-24324: service handle not initialized in <b>/htdocs/admin/lib/error_handler.php</b> on line <b>0</b><br>

such error messages in apache error_log file.  Interestingly,  There is no  OCI calls in error_handler.php file. But  this file is included by oci8.php, which has  oci connect  and other functions.  oci8.php is  included by other php files (for example product_edit.phtml).
   When I  remove the line including "error_handler.php" in oci8.php , this time same error is occured in oci8.php file.

<b>Warning</b>:  failed to rollback outstanding transactions!: ORA-24324: service handle not initialized in <b>/htdocs/admin/lib/oci8.php</b> on line <b>0</b><br>

oci8.php file is including oci related custom database functions. Probably this error appears after calling OCIExecute( $stmt, OCI_DEFAULT ).  I need an urgent help. 
Thanks.

my code snippet:

product_edit1.phtml
-----------------------
<?
if ( !$submit ) {
   require( "lib/login.php" );
}
include( "lib/lib_html.php" );
include( "conf/deppo.conf.php" );
require( "lib/oci8.php" );
...

oci8.php
-----------------
<?
include( "conf/deppo.conf.php" );
if ( !defined( "ADMIN_OCI8_LIB" ) ) {
  define( "ADMIN_OCI8_LIB", 1 );
  global $con, $query;

  // include custom error handler
  include( "lib/error_handler.php" );
  $USER = "user";
  $PASSWD = "secret";

  if ( $con == "" ) {
     $con = OCINLogon("$USER", "$PASSWD");
  }

  if ( $con == FALSE ) {
    echo OCIError( $con );
    exit;
  }

....
error_handler.php
---------------------
<?
if ( !defined( "ADMIN_ERROR_HANDLER_LIB" ) ) {
  define( "ADMIN_ERROR_HANDLER_LIB", 1 );
  // deppo error and warning handler functions and variables
  define( ERR_ERROR, E_ERROR | E_CORE_ERROR );
  define( ERR_WARNING, E_WARNING );
  define( ERR_NOTICE, E_NOTICE );
  error_reporting( ERR_ERROR | ERR_WARNING | ERR_NOTICE );

  function Err_ErrorHandler ($errno, $errstr, $errfile, $errline) {
    switch ($errno) {
      case ERR_ERROR:
        $err_erstr  = "<b>ERROR</b> [$errno]: $errstr<br>\n";
        $err_erstr .= "  Fatal error in line ".$errline." of file ".$errfile;
        exit -1;
        break;
      case ERR_WARNING:
        $err_erstr = "<b>WARNING</b> [$errno]: $errstr<br>\n";
        $err_erstr .= " error in line ".$errline." of file ".$errfile;
        break;
      case ERR_NOTICE:
        $err_erstr = "";
        break;
      default:
        $err_erstr = "<b>ERROR-</b> [$errno]: $errstr<br>\n";
        $err_erstr .= " error in line ".$errline." of file ".$errfile;
        break;
    }
    if ( $err_erstr !="" ) {
      Err_MailError($err_erstr);
    }
  }
  $old_error_handler = set_error_handler( "Err_ErrorHandler" );

  function Err_MailError( &$err ) {

...

My conf:
----------
OS: Red Hat Linux 6.2 kernel 2.2.16-3
Web server: Apache 4.0.3p1
Oracle: Oracle 8i Enterprise Edition 8.1.6 for Linux
Configure command:
'./configure' '--with-apache=../apache_1.3.14'
'--with-oci8=/oracle/app/oracle/product/8.1.6' '--with-ldap' '--with-gd=shared'
'--with-jpeg-dir' '--with-png-dir' '--with-ttf' '--with-xpm-dir=/usr/X11R6'
'--enable-shared-pdflib' '--with-mhash' '--enable-bcmath' '--enable-calendar'
'--enable-inline-optimization' '--enable-libgcc' '--enable-safe-mode'
'--enable-shared' '--enable-sigchild' '--enable-static' '--enable-sysvsem'
'--enable-sysvshm' '--with-swf=../swf_099' '--disable-posix-threads'
'--with-mm=/usr/local/mm' '--enable-ftp' '--enable-sockets'
'--with-curl=../curl-7.4.2' '--with-mcrypt' '--without-mysql' '--enable-wddx'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-18 06:48 UTC] thies@php.net
plz try to create a small code snippet that demonstrates 
the behaviour.

BTW: why are you using OCINlogon?



 [2001-02-18 13:07 UTC] erol at infotron dot com dot tr
I'm sorry for the long snippets. I am using OCINLogon because manual says it should be used to isolate a set of transactions.
 [2001-02-21 07:37 UTC] thies@php.net
i need a _short_ testcase which allows me to reproduce 
your problem on my local dev-environment. plz try to 
create this testcase (<50lines) elsewise your problem 
won't get fixed.


 [2001-04-10 10:03 UTC] sniper@php.net
No feedback. If this happens also with soon to be released 
PHP 4.0.5, reopen this bug report with a SHORT example 
script that can be used to reprocude this.

--Jani

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 05:03:38 2023 UTC