php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9313 considering Apache multithread server
Submitted: 2001-02-17 04:06 UTC Modified: 2001-06-14 20:51 UTC
From: ergond at gmx dot net Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.4pl1 OS: Windows 9x/W2K
Private report: No CVE-ID: None
 [2001-02-17 04:06 UTC] ergond at gmx dot net
I have a problem with uding Dl() function on my Win32/Apache/Php4 server. The error message is 'unable to load extension on multithread server'. But Apache isn't multithread server, is it ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-17 04:08 UTC] cynic@php.net
win32 Apache is multithreaded.
 [2001-02-17 04:50 UTC] ergond at gmx dot net
May I ask how can I use dll extensions with php4/windows/apache configuration ?
 [2001-02-17 04:54 UTC] cynic@php.net
sure. load them in php.ini. this is described in the manual, and the readme file that comes with the distro.
 [2001-02-17 09:27 UTC] ergond at gmx dot net
I was trying to load php4 extension libraries at startup (editing php.ini). However, none of the modules was loaded. the error log was :

 - One of the library files needed to run this application cannot be found.
 in Unknown on line 0
PHP Warning:  Unable to load dynamic library 'd:\php\extensions/php_ifx.dll' - O
ne of the library files needed to run this application cannot be found.
 in Unknown on line 0
PHP Warning:  Unable to load dynamic library 'd:\php\extensions/php_mssql65.dll'
 - One of the library files needed to run this application cannot be found.
 in Unknown on line 0
PHP Warning:  Unable to load dynamic library 'd:\php\extensions/php_oci8.dll' -
One of the library files needed to run this application cannot be found.
 in Unknown on line 0
PHP Warning:  Unable to load dynamic library 'd:\php\extensions/php_oracle.dll'
- One of the library files needed to run this application cannot be found.
 in Unknown on line 0
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 0 in (none)
PHP Warning:  Unable to load dynamic library 'd:\php\extensions/php_sybase_ct.dl
l' - One of the library files needed to run this application cannot be found.
 in Unknown on line 0

I am sure that the path is correct (php is installed on d:/php, extensions in d:/php/extensions.)

This is how my php.ini file is configured :

;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;
include_path	=                   ; UNIX: "/path1:/path2"  Windows: "\path1;\path2"
doc_root = "d:\programs"					; the root of the php pages, used only if nonempty
user_dir		=					; the directory under which php opens the script using /~username, used only if nonempty
extension_dir	= "d:\php\extensions"				; directory in which the loadable extensions (modules) reside
enable_dl		= On				; Whether or not to enable the dl() function.
									; The dl() function does NOT properly work in multithreaded
									; servers, such as IIS or Zeus, and is automatically disabled
									; on them.


;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;
file_uploads	= On				; Whether to allow HTTP file uploads
;upload_tmp_dir	=	                ; temporary directory for HTTP uploaded files (will use system default if not specified)
upload_max_filesize = 2M		    ; Maximum allowed size for uploaded files


;;;;;;;;;;;;;;;;;;
; Fopen wrappers ;
;;;;;;;;;;;;;;;;;;
allow_url_fopen = On                ; Wheter to allow trating URLs like http:... or ftp:... like files


;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
; if you wish to have an extension loaded automaticly, use the
; following syntax:  extension=modulename.extension
; for example, on windows,
; extension=msql.dll
; or under UNIX,

; extension=msql.so

; Note that it should be the name of the module only, no directory information 
; needs to go here.  Specify the location of the extension with the extension_dir directive above.


;Windows Extensions
;Note that MySQL and ODBC support is now built in, so no dll is needed for it.
;

extension=php_bz2.dll
extension=php_cpdf.dll
extension=php_curl.dll
extension=php_cybercash.dll
extension=php_db.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_domxml.dll
extension=php_dotnet.dll
extension=php_exif.dll
extension=php_fdf.dll
extension=php_filepro.dll
extension=php_gd.dll
extension=php_gettext.dll
extension=php_ifx.dll
extension=php_iisfunc.dll
extension=php_imap.dll
extension=php_interbase.dll
extension=php_java.dll
extension=php_ldap.dll
extension=php_mhash.dll
extension=php_mssql65.dll
extension=php_mssql70.dll
extension=php_oci8.dll
extension=php_openssl.dll
extension=php_oracle.dll
extension=php_pdf.dll
extension=php_pgsql.dll
extension=php_printer.dll
extension=php_sablot.dll
extension=php_snmp.dll
extension=php_sybase_ct.dll
extension=php_yaz.dll
extension=php_zlib.dll

 [2001-02-17 18:29 UTC] cynic@php.net
The extensions that failed to load depend on external libraries that need to be in your system's path in order to be found. 

See http://bugs.php.net/?id=9037.
 [2001-06-10 19:47 UTC] ergond at gmx dot net
[Sun Jun 10 19:37:01 2001] [error] [client 127.0.0.1] PHP Warning:  Unable to lo
ad dynamic library 'c:\php/php_gd400.dll' - A device attached to the system is n
ot functioning.

[Sun Jun 10 19:37:02 2001] [error] [client 127.0.0.1]  in Unknown on line 0

Trying to use PHP_GD40x.dll but looks like I had this pb till I set up the 1.3.20 Apache Server.

Any idea how to work it out plz!
 [2001-06-14 20:51 UTC] sniper@php.net
this is not support forum. Read the install.txt and
search the net with e.g. www.google.com and you will
find answers. No bugs.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 21:01:23 2020 UTC