php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9299 magic quotes On - always
Submitted: 2001-02-16 10:49 UTC Modified: 2001-06-18 20:03 UTC
From: ajandris at parks dot lv Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.4pl1 OS: WinNT4.0 wrkst sp6
Private report: No CVE-ID: None
 [2001-02-16 10:49 UTC] ajandris at parks dot lv
Magic quotes in PHP.ini file:

; Magic quotes
magic_quotes_gpc=Off	; magic quotes for incoming GET/POST/Cookie data
magic_quotes_runtime=Off	; magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_sybase=Off	; Use Sybase-style magic quotes (escape ' with '' instead of \')

In fields I wrote: ' " at the end of field
Output:
HTTP_POST_VARS["mngr1_surname"] ->   2 surname a \'\"

on Linux it works:
HTTP_POST_VARS["address1"] ->    Address 1 ' "

I try to change to magic_quotes=On. It can' t helps.

IIS 4.0 ,CGI version

Andris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-05 02:29 UTC] sniper@php.net
And you are sure the php.ini file gets read by PHP?
Check the phpinfo() output for this.

--Jani

 [2001-06-05 09:21 UTC] ajandris at parks dot lv
I don't have any instance of version 4.0.4p1, but on v4.0.5 it seems
to works fine.

win2K, Apache/1.3.19 ISAPI.

As I remember correct, phpinfo() function showed php.ini file as php.ini, not
full path as it is on my computer today ...

Andris
mailto:ajandris@parks.lv

 [2001-06-12 10:52 UTC] dbeu@php.net
so is it fixed?
 [2001-06-13 05:55 UTC] ajandris at parks dot lv
I told, I can't reproduce situation because I have not previous environment. It is not a problem for me today.

Andris
 [2001-06-18 20:03 UTC] sniper@php.net
If it doesn't exist now, it most likely is fixed..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 02:01:26 2019 UTC