php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #9266 Unable to load 14 of php's extensions
Submitted: 2001-02-14 16:41 UTC Modified: 2010-05-26 11:37 UTC
Votes:7
Avg. Score:4.0 ± 1.4
Reproduced:5 of 6 (83.3%)
Same Version:1 (20.0%)
Same OS:2 (40.0%)
From: mikemyers at swi dot hu Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.4pl1 OS: WinMe, Win98, Win2000
Private report: No CVE-ID: None
 [2001-02-14 16:41 UTC] mikemyers at swi dot hu
I spent almost 2 day trying to figure out how to load the sybase extension under windows. I tried everything I could, but 14 of the extensions would not load under WinMe, Win98, Win2000, with any combination of apache, pws, iis. The extension_dir is just set all fine, and the rest of the extensions load and function well.

I only wanted to get some data from a sybase db. I could actually solve it with ODBC, but I still thought it's not the real way.

I discussed this problem on the local php mailing list, everyone knew it, noone knew why. I searched through the php manual and the rest of the web just to find a fraction of information that could be helpful either way, but there was no.

The extensions that made me 2 horribe days:

php_curl.dll
php_fdf.dll
php_gettext.dll
php_ifx.dll
php_interbase.dll
php_ldap.dll
php_mssql65.dll
php_mssql70.dll
php_oci8.dll
php_openssl.dll
php_oracle.dll
php_sablot.dll
php_sybase_ct.dll
php_yaz.dll

A sample message:
PHP Warning:  Unable to load dynamic library 'c:\php\extensions\php_sybase_ct.dll'

My question is if it is possible to load these extensions some way, or should I give up trying, becouse they will never load.

Thank you a lot.

I wish you nice developing.

Best regards:

Mike Myers

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 16:49 UTC] hholzgra@php.net
all of theese extensions depend on other DLLs 
being installed on your system
like, for example, sybase_ct client DLLs
(this is the native sybase call interface, _not_ the ODBC stuff)

maybe we could improve the error message?
(moved to feature request)
 [2001-02-14 16:49 UTC] hholzgra@php.net
all of theese extensions depend on other DLLs 
being installed on your system
like, for example, sybase_ct client DLLs
(this is the native sybase call interface, _not_ the ODBC stuff)

maybe we could improve the error message?
(moved to feature request)
 [2001-02-14 20:07 UTC] mikemyers at swi dot hu
Yes, a more detailed error message, or/and two more lines in the manual could have saved me some time. And maybe it would for others too.

Thank you.
 [2002-01-06 13:18 UTC] jan@php.net
so better documentation is needed for extensions that rely on external libraries.
 [2002-01-06 13:34 UTC] irc-html@php.net
The extensions are all (mostly) listed in a table at http://www.php.net/manual/en/install.windows.php#install.windows.extensions which also lists if the extension is dependent upon a specific library (another dll).

Most of the extension documentation also lists 'You need xxx to use this extension', or 'In order to use this extension you need to install xxx', etc.  I think it is clearly documented in the manual.  A possibility would be to improve the error message, perhaps 'php_xxx.dll:  This extension requires xxx library installed', something simliar would be helpful.

Changing to feature request.
 [2004-12-23 12:35 UTC] vishonly at yahoo dot co dot in
i completly agree
i also spend almost 2 days
for connecting to remote sybase server

couldnot load php_sybase_ct.dll

i know it requires other files like libct.dll but how to get them

i know its not php bug but atleast the ppl who have worked on this can reply
 [2009-05-04 15:06 UTC] pajoye@php.net
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.


 [2010-05-26 11:01 UTC] moufid dot zeribi at murex dot com
This issue is reproductible under Win2003 Server - IIS6 - PHP 5.3.2. That would be great to update the status of this ticket for the latest PHP version.
Regards
 [2010-05-26 11:09 UTC] pajoye@php.net
-Status: Wont fix +Status: Bogus -Package: Feature/Change Request +Package: *General Issues
 [2010-05-26 11:09 UTC] pajoye@php.net
There is no issue, read the install guide to learn how to install PHP, or use the installer.
 [2010-05-26 11:28 UTC] moufid dot zeribi at murex dot com
Sorry for the misunderstanding. I was mentionning that a detailed error message is still missing when it's about missing external libraries like the one described for php_sybase_ct.dll with PHP 5.3.2 (the latest version as of today) and that would be useful to have such info

Regards
 [2010-05-26 11:37 UTC] pajoye@php.net
We can't provide this message as php does not have the hand at this stage.
 [2010-05-27 17:51 UTC] moufid dot zeribi at murex dot com
At the end, I succeed to solve the php_sybase_ct.dll that couldn't be loaded letting you unable to connect to sybase databases via PHP.I just needed to reinstall PHP with an installer that includes php_sybase_ct.dll, so no need to copy it from somewhere else to the extensions directory. To be more clear I first installed this package php-5.3.2-nts-Win32-VC9-x86.msi which doesn't come with the dll and used instead php-5.3.2-nts-Win32-VC6-x86.msi which does from http://windows.php.net/download.
The following tool really helped me to find the solution : http://www.dependencywalker.com/, by telling me that php_sybase_ct.dll was missing a specific PHP dll which couldn't be found in the package I installed in the first stage.

I wish I found this solution somewhere but as many guys fell into this problem (sometimes since 2001!) and all suggestion/resolution where turning around a wrong direction PHP.ini, extensions folder directives malformatted... I find it important to share this point!
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC