php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9231 when usign ob_gzhandler HTTP HEAD does not work
Submitted: 2001-02-12 15:05 UTC Modified: 2001-06-14 14:32 UTC
From: boian at bonev dot com Assigned: andre (profile)
Status: Closed Package: Output Control
PHP Version: 4.0 Latest CVS (12/02/2001) OS: Linux glibc 2.1
Private report: No CVE-ID: None
 [2001-02-12 15:05 UTC] boian at bonev dot com
php.ini:
output_handler = ob_gzhandler

tests:

a plain html request:

root@orange:~# telnet 0 80
Trying 0.0.0.0...
Connected to 0.
Escape character is '^]'.
HEAD / HTTP-1.0   

HTTP/1.1 200 OK
Date: Mon, 12 Feb 2001 19:57:47 GMT
Server: Apache/1.3.17 (Unix) PHP/4.0.5-dev
Last-Modified: Mon, 04 Dec 2000 13:01:35 GMT
ETag: "ac04-1f6-3a2b95af"
Accept-Ranges: bytes
Content-Length: 502
Connection: close
Content-Type: text/html

Connection closed by foreign host.

php script request:

root@orange:~# telnet 0 80
Trying 0.0.0.0...
Connected to 0.
Escape character is '^]'.
HEAD / HTTP-1.0 
host: mail.bonev.com

same php script, but now GET instead of HEAD:

root@orange:~# telnet 0 80
Trying 0.0.0.0...
Connected to 0.
Escape character is '^]'.
GET / HTTP/1.0
host: mail.bonev.com

HTTP/1.1 302 Found
Date: Mon, 12 Feb 2001 19:57:22 GMT
Server: Apache/1.3.17 (Unix) PHP/4.0.5-dev
X-Powered-By: PHP/4.0.5-dev
location: /6bcf63364235c745643078ff1e0df2d6/
Connection: close
Content-Type: text/html

Connection closed by foreign host.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 12:25 UTC] andre@php.net
shouldn't it reaad

HEAD / HTTP/1.0


bogus

 [2001-02-17 11:50 UTC] boian at bonev dot com
HTTP-1.0 and HTTP/1.0 are just the same for apache

this bug report says that ob_gzhandler crashes HEAD requests when php is an apache module
 [2001-02-17 11:51 UTC] bbonev@php.net
reopened
 [2001-02-19 23:03 UTC] andre@php.net
similar to Bug id #9031

 [2001-02-19 23:08 UTC] boian at bonev dot com
yep. both seem to be apache SAPI module problem related to ob in general (at least i suppose so)
 [2001-06-14 14:32 UTC] sniper@php.net
I can't reproduce this with PHP 4.0.6RC3

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Oct 20 08:01:25 2018 UTC