php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9214 Apache dumps core on startup
Submitted: 2001-02-11 11:52 UTC Modified: 2001-02-11 15:16 UTC
From: colitti at xmedia dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.0.4pl1 OS: RedHat Linux 6.2
Private report: No CVE-ID: None
 [2001-02-11 11:52 UTC] colitti at xmedia dot net
Apache 1.3.17 dumps core on startup if I try to load the php module dynamically.

These are my dynamic loading settings:

LoadModule agent_log_module   libexec/mod_log_agent.so
LoadModule referer_log_module libexec/mod_log_referer.so
LoadModule info_module        libexec/mod_info.so
LoadModule rewrite_module     libexec/mod_rewrite.so
LoadModule expires_module     libexec/mod_expires.so
LoadModule php4_module        libexec/libphp4.so

What is really strange is that if I disable mod_log_agent and mod_log_referer, it works fine!


I configured PHP with:

./configure --with-apxs=/usr/local/apache/bin/apxs --enable-ftp --without-mysql --with-oci8=/home/oracle/u01/app/oracle/product/8.1.7 --with-pgsql=/usr/lib

and then with --enable-debug to get the following backtrace:



#0  0x4000af21 in _dl_debug_state () at dl-debug.c:56
#1  0x40183156 in _dl_close (map=0x80d52e0) at dl-close.c:195
#2  0x400a1430 in dlclose_doit (handle=0x80d52e0) at dlclose.c:26
#3  0x4000ac3b in _dl_catch_error (errstring=0x400a3080,
    operate=0x400a1418 <dlclose_doit>, args=0x80d52e0) at dl-error.c:141
#4  0x400a18b9 in _dlerror_run (operate=0x400a1418 <dlclose_doit>,
    args=0x80d52e0) at dlerror.c:125
#5  0x400a13fe in dlclose (handle=0x80d52e0) at dlclose.c:32
#6  0x8088390 in ap_os_dso_unload ()
#7  0x8066af0 in unload_module ()
#8  0x806914e in run_cleanups ()
#9  0x806797d in ap_clear_pool ()
#10 0x8077d63 in standalone_main ()
#11 0x8078613 in main ()
#12 0x400bc9cb in __libc_start_main (main=0x80782cc <main>, argc=4,
    argv=0xbffffb04, init=0x804ed8c <_init>, fini=0x80acbcc <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffafc)
    at ../sysdeps/generic/libc-start.c:92

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-11 11:58 UTC] jmoore@php.net
Does apache start when PHP is not enabled? Also try shuffling the order things are loaded in.. it is important in some cases although I do not know if this is the case here. To me it looks like it is crashing before it even looks at PHP.

James
 [2001-02-11 12:15 UTC] rasmus@php.net
Sounds like the normal glibc-2.1.x + libpthreads bug.  If you recompile your Apache server and add -lpthreads to the LIBS line I bet this will go away.
 [2001-02-11 15:08 UTC] colitti at xmedia dot net
Yessir!
I recompiled apache with -lpthread as you said and it's running fine.

Thanks a million.

Lorenzo
 [2001-02-11 15:16 UTC] jmoore@php.net
Bogusify it
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 16:01:24 2020 UTC