php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9210 Failed opening 'path' for inclustion in unknow line 0
Submitted: 2001-02-11 08:43 UTC Modified: 2001-05-28 00:24 UTC
From: mike at powertoyspcs dot com Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.3pl1 OS: Mandrake Linux 7.2
Private report: No CVE-ID:
 [2001-02-11 08:43 UTC] mike at powertoyspcs dot com
whenever I run a php document under the root directory.

I am running apache 1.3.14,mod_ssl 2.7.1 and the mysql patch.


Warning: Failed opening
'/var/www/html/mymarket/admin/index.php' for inclusion
(include_path='') in Unknown on line 0



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-11 08:53 UTC] derick@php.net
Try setting the include path to "."
 [2001-02-11 09:13 UTC] mike at powertoyspcs dot com
Derick,
I did. It had 0 effect. I am still getting the same error.

this entry is typed from the php.ini file exactly:

include_path=".";


 [2001-02-11 09:15 UTC] mike at powertoyspcs dot com
Derick,
I did. It had 0 effect. I am still getting the same error.

this entry is typed from the php.ini file exactly:

include_path=".";


 [2001-02-11 09:20 UTC] derick@php.net
Can you put up the output of phpinfo(); on the net?
 [2001-02-11 09:38 UTC] mike at powertoyspcs dot com
try http://206.102.15.235/test.php .  If you can't e-mail me
and I will send you a copy of my php.ini file. It won't cut
and paste into this form for some reason.

Mike
 [2001-02-11 09:40 UTC] mike at powertoyspcs dot com
Derick,
it come up on the box I am working on and others inside my
intranet. what did you want to see?
 [2001-02-11 10:00 UTC] derick@php.net
The output of <?php phpinfo(); ?> and your php.ini file please.
 [2001-02-11 10:06 UTC] mike at powertoyspcs dot com
[PHP Logo]
PHP Version 4.0.3pl1

System Linux AES.MandrakeSoft.com 2.2.17-21mdk #1 Thu Oct 5
13:16:08 CEST 2000 i686 unknown
Build Date Oct 23 2000
Configure Command './configure' '--with-apxs=/usr/sbin/apxs'
'--without-mysql' '--disable-static' '--disable-debug'
'--enable-pic' '--enable-inline-optimization'
'--prefix=/usr' '--with-zlib' '--with-config-file-path=/etc'
'--enable-magic-quotes' '--enable-debugger'
'--enable-track-vars' '--enable-safe-mode'
'--with-exec-dir=/usr/bin' '--with-regex=system'
'--with-versioning' '--enable-dba=shared' '--with-gdbm'
'--with-db2' '--enable-sysvsem' '--enable-sysvshm'
'--with-mod_charset' '--enable-force-cgi-redirect'
'--with-mm' '--enable-trans-sid' '--with-dbase'
'--with-filepro' '--enable-yp' '--enable-ftp' '--with-xml'
'--with-gettext'
Server API Apache
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc
ZEND_DEBUG disabled
Thread Safety disabled

[Zend logo] This program makes use of the Zend scripting
language engine:
Zend Engine v1.0.3, Copyright (c) 1998-2000 Zend Technologies


PHP 4.0 Credits
Configuration
PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference
On On
arg_separator
& &
asp_tags
Off Off
auto_append_file
no value no value
auto_prepend_file
no value no value
browscap
no value no value
default_charset
no value no value
default_mimetype
text/html text/html
define_syslog_variables
Off Off
disable_functions
no value no value
display_errors
On On
display_startup_errors
Off Off
doc_root
no value no value
enable_dl
On On
error_append_string
Off Off
error_log
no value no value
error_prepend_string
Off Off
error_reporting
no value no value
expose_php
On On
extension_dir
/usr/lib/php/extensions /usr/lib/php/extensions
file_uploads
1 1
gpc_order
GPC GPC
highlight.bg
#FFFFFF #FFFFFF
highlight.comment
#FF8000 #FF8000
highlight.default
#0000BB #0000BB
highlight.html
#000000 #000000
highlight.keyword
#007700 #007700
highlight.string
#DD0000 #DD0000
html_errors
On On
ignore_user_abort
Off Off
implicit_flush
Off Off
include_path
.:/usr/lib/php .:/usr/lib/php
log_errors
Off Off
magic_quotes_gpc
On On
magic_quotes_runtime
Off Off
magic_quotes_sybase
Off Off
max_execution_time
30 30
open_basedir
no value no value
output_buffering
Off Off
post_max_size
8M 8M
precision
14 14
register_argc_argv
On On
register_globals
On On
safe_mode
Off Off
safe_mode_exec_dir
1 1
sendmail_from
no value no value
sendmail_path
/usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
short_open_tag
On On
SMTP
localhost localhost
sql.safe_mode
Off Off
track_errors
Off Off
upload_max_filesize
2M 2M
upload_tmp_dir
no value no value
user_dir
no value no value
variables_order
no value no value
y2k_compliance
Off Off

zlib
ZLib Support enabled
Compiled Version 1.1.3
Linked Version 1.1.3

yp
YP Support enabled

xml
XML Support active

standard
Regex Library System library enabled
Dynamic Library Support enabled
Path to sendmail /usr/sbin/sendmail -t -i

Directive Local Value Master Value
assert.active
1 1
assert.bail
0 0
assert.callback
no value no value
assert.quiet_eval
0 0
assert.warning
1 1
safe_mode_allowed_env_vars
PHP_ PHP_
safe_mode_protected_env_vars
LD_LIBRARY_PATH LD_LIBRARY_PATH
session.use_trans_sid
1 1

session
Session Support enabled

Directive Local Value Master Value
session.auto_start
Off Off
session.cache_expire
180 180
session.cache_limiter
nocache nocache
session.cookie_domain
no value no value
session.cookie_lifetime
0 0
session.cookie_path
/ /
session.entropy_file
no value no value
session.entropy_length
0 0
session.gc_maxlifetime
1440 1440
session.gc_probability
1 1
session.name
PHPSESSID PHPSESSID
session.referer_check
no value no value
session.save_handler
files files
session.save_path
/tmp /tmp
session.serialize_handler
php php
session.use_cookies
On On

posix
Revision $Revision: 1.26 $

pcre
PCRE (Perl Compatible Regular Expressions) Support enabled
PCRE Library Version 3.1 09-Feb-2000

gettext
GNU GetText Support enabled

ftp
FTP support enabled

apache
APACHE_INCLUDE
APACHE_TARGET
Apache Version Apache-AdvancedExtranetServer/1.3.14
Apache Release 10314100
Apache API Version 19990320
Hostname:Port linux.powertoyspcs.com:10021
User/Group apache(48)/235
Max Requests Per Child: 500
Keep Alive: on
Max Per Connection: 100
Timeouts Connection: 300
Keep-Alive: 15
Server Root /etc/httpd
Loaded Modules mod_php4, mod_ssl, mod_setenvif,
mod_usertrack, mod_headers, mod_expires, mod_digest,
mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias,
mod_proxy, mod_userdir, mod_actions, mod_imap, mod_asis,
mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info,
mod_status, mod_negotiation, mod_mime, mod_log_referer,
mod_log_agent, mod_log_config, mod_env, mod_so, http_core

Apache Environment
Variable Value
DOCUMENT_ROOT /var/www/html
HTTP_ACCEPT */*
HTTP_ACCEPT_ENCODING gzip,deflate,compress,identity
HTTP_ACCEPT_LANGUAGE en
HTTP_CONNECTION keep-alive
HTTP_HOST localhost
HTTP_KEEP_ALIVE 300
HTTP_USER_AGENT Mozilla/5.0 (X11; U; Linux 2.2.17-21mdksmp
i686; en-US; m18) Gecko/20010131 Netscape6/6.01
PATH /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
REMOTE_ADDR 127.0.0.1
REMOTE_PORT 1122
SCRIPT_FILENAME /var/www/html/test.php
SERVER_ADDR 127.0.0.1
SERVER_ADMIN mike@powertoyspcs.com
SERVER_NAME linux.powertoyspcs.com
SERVER_PORT 10021
SERVER_SIGNATURE
SERVER_SOFTWARE Apache-AdvancedExtranetServer/1.3.14
(Linux-Mandrake/2mdk) PHP/4.0.3pl1 mod_ssl/2.7.1 OpenSSL/0.9.5a
GATEWAY_INTERFACE CGI/1.1
SERVER_PROTOCOL HTTP/1.1
REQUEST_METHOD GET
QUERY_STRING
REQUEST_URI /test.php
SCRIPT_NAME /test.php

HTTP Headers Information
HTTP Request Headers
HTTP Request GET /test.php HTTP/1.1
Accept */*
Accept-Encoding gzip,deflate,compress,identity
Accept-Language en
Connection keep-alive
Host localhost
Keep-Alive 300
User-Agent Mozilla/5.0 (X11; U; Linux 2.2.17-21mdksmp i686;
en-US; m18) Gecko/20010131 Netscape6/6.01
HTTP Response Headers
X-Powered-By PHP/4.0.3pl1
Keep-Alive timeout=15, max=100
Connection Keep-Alive
Transfer-Encoding chunked
Content-Type text/html

Additional Modules
sysvshm
sysvsem
filepro
dbase
Session MM

Environment
Variable Value
PWD /
HOSTNAME linux.powertoyspcs.com
MACHTYPE i586-mandrake-linux-gnu
LANG en
DISPLAY :0
SHLVL 2
SHELL /bin/bash
HOSTTYPE i586
OSTYPE linux-gnu
TERM dumb
HOME /root
PATH /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
_ /bin/nice

PHP Variables
Variable Value
PHP_SELF /test.php
HTTP_SERVER_VARS["DOCUMENT_ROOT"] /var/www/html
HTTP_SERVER_VARS["HTTP_ACCEPT"] */*
HTTP_SERVER_VARS["HTTP_ACCEPT_ENCODING"]
gzip,deflate,compress,identity
HTTP_SERVER_VARS["HTTP_ACCEPT_LANGUAGE"] en
HTTP_SERVER_VARS["HTTP_CONNECTION"] keep-alive
HTTP_SERVER_VARS["HTTP_HOST"] localhost
HTTP_SERVER_VARS["HTTP_KEEP_ALIVE"] 300
HTTP_SERVER_VARS["HTTP_USER_AGENT"] Mozilla/5.0 (X11; U;
Linux 2.2.17-21mdksmp i686; en-US; m18) Gecko/20010131
Netscape6/6.01
HTTP_SERVER_VARS["PATH"]
/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
HTTP_SERVER_VARS["REMOTE_ADDR"] 127.0.0.1
HTTP_SERVER_VARS["REMOTE_PORT"] 1122
HTTP_SERVER_VARS["SCRIPT_FILENAME"] /var/www/html/test.php
HTTP_SERVER_VARS["SERVER_ADDR"] 127.0.0.1
HTTP_SERVER_VARS["SERVER_ADMIN"] mike@powertoyspcs.com
HTTP_SERVER_VARS["SERVER_NAME"] linux.powertoyspcs.com
HTTP_SERVER_VARS["SERVER_PORT"] 10021
HTTP_SERVER_VARS["SERVER_SIGNATURE"]
HTTP_SERVER_VARS["SERVER_SOFTWARE"]
Apache-AdvancedExtranetServer/1.3.14 (Linux-Mandrake/2mdk)
PHP/4.0.3pl1 mod_ssl/2.7.1 OpenSSL/0.9.5a
HTTP_SERVER_VARS["GATEWAY_INTERFACE"] CGI/1.1
HTTP_SERVER_VARS["SERVER_PROTOCOL"] HTTP/1.1
HTTP_SERVER_VARS["REQUEST_METHOD"] GET
HTTP_SERVER_VARS["QUERY_STRING"]
HTTP_SERVER_VARS["REQUEST_URI"] /test.php
HTTP_SERVER_VARS["SCRIPT_NAME"] /test.php
HTTP_SERVER_VARS["PATH_TRANSLATED"] /var/www/html/test.php
HTTP_SERVER_VARS["PHP_SELF"] /test.php
HTTP_SERVER_VARS["argv"]

Array
(
)
HTTP_SERVER_VARS["argc"] 0
HTTP_ENV_VARS["PWD"] /
HTTP_ENV_VARS["HOSTNAME"] linux.powertoyspcs.com
HTTP_ENV_VARS["MACHTYPE"] i586-mandrake-linux-gnu
HTTP_ENV_VARS["LANG"] en
HTTP_ENV_VARS["DISPLAY"] :0
HTTP_ENV_VARS["SHLVL"] 2
HTTP_ENV_VARS["SHELL"] /bin/bash
HTTP_ENV_VARS["HOSTTYPE"] i586
HTTP_ENV_VARS["OSTYPE"] linux-gnu
HTTP_ENV_VARS["TERM"] dumb
HTTP_ENV_VARS["HOME"] /root
HTTP_ENV_VARS["PATH"]
/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
HTTP_ENV_VARS["_"] /bin/nice

PHP License

This program is free software; you can redistribute it
and/or modify it under the terms of the PHP License as
published by the PHP Group and included in the distribution
in the file: LICENSE

This program is distributed in the hope that it will be
useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

If you did not receive a copy of the PHP license, or have
any questions about PHP licensing, please contact
license@php.net.


 [2001-02-11 10:07 UTC] mike at powertoyspcs dot com
Derick,
I have changed the include_path in my .ini file. I have
shutdown and restarted the apache server also. I notice the
path does not change
 [2001-02-11 10:12 UTC] derick@php.net
What is the location of your php.ini ? It should in /etc from what I"ve seen from teh phpinfo() output.
 [2001-02-11 10:17 UTC] mike at powertoyspcs dot com
it is in the /etc directory.
 [2001-02-11 10:26 UTC] mike at powertoyspcs dot com
Derick,
check your e-mail. I sent you my ini file.
 [2001-04-29 05:41 UTC] jmoore@php.net
can you check the permissions in 'path' please as this could be the cause of it (if PHP cant read the file due to permissions)

- James
 [2001-05-28 00:24 UTC] sniper@php.net
no feedback, considered fixed.

 [2002-11-14 07:35 UTC] mimmesmo at yahoo dot com
I've trying to solve the problem below for 3 days. 

I have an auto_prepend_file and it doesn't have the right privileges. My auto_prepend_file was outside the php pages directory tree, and I forgot to give access to user nobody to it (in my case, user nobody). 

The message for this error should be "file access denied" or something related to permissions. The way it is, it looks like a strange problem with include or something.

Rodrigo
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 09:02:23 2014 UTC