php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9143 wrong Apache version shown
Submitted: 2001-02-07 03:19 UTC Modified: 2001-02-16 14:33 UTC
From: cynic at mail dot cz Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0 Latest CVS (07/02/2001) OS: NT 5
Private report: No CVE-ID: None
 [2001-02-07 03:19 UTC] cynic at mail dot cz
php4-200102060545
apache-1.3_20010207051200

Apache version property in the Apache section of phpinfo() shows Apache/1.3.17 (wrong), but HTTP_SERVER_VARS["SERVER_SIGNATURE"] and HTTP_SERVER_VARS["SERVER_SOFTWARE"] correctly display 1.3.18-dev. I'm not sure if this is Apache or PHP problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 13:43 UTC] sniper@php.net
Most likely Apache problem as you're using a CVS version of it too?
Anyway, this isn't anything fatal enough to be called a bug.. :)

IF it happens with release versions..maybe then.

 [2001-02-16 14:33 UTC] cynic@php.net
Well, you _don't_ consider it a feature, do you? :)

Nevertheless, it's ok with apache-1.3_20010212171201 / php4-200102120845.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 10:01:23 2020 UTC