php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #908 Problem with German Umlauts in $PHP_AUTH_USER
Submitted: 1998-11-09 15:09 UTC Modified: 1998-11-10 22:24 UTC
From: geschke at infosoc dot uni-koeln dot de Assigned:
Status: Closed Package: Misbehaving function
PHP Version: 3.0.5 OS: Linux / SUN Solaris
Private report: No CVE-ID: None
 [1998-11-09 15:09 UTC] geschke at infosoc dot uni-koeln dot de
By authenticating with the help of $PHP_AUTH_USER / $PHP_AUTH_PW, PHP has problems to set these variables when they include German Umlauts (???????). 

Here a list with correct and incorrect values:

$PHP_AUTH_USER:       result:
t?ten                        t?ten                (ok)
t?ten                        t?ten                (ok)
t?ten                        t?ten                (ok)
t?t?r                         t?t                  (error)
t?t?r                         t?t                  (error)
t?t?r                         t?t                  (error)
t?t?r?                       t?t                  (error)
t?t?r?                       t?t                  (error)
t?t?r?                       t?t                  (error)
da?                         da?                  (ok)
?ad                         '' (emtpy string)      (error)
T?R                        T?R                  (ok)
T?R?                      T?R                  (error)
?sterreich                '' (empty string)      (error)
?ste                        '' (empty string)      (error)
?st                         '' (empty string)      (error)
Tabalug?                Tabalug?             (ok)
Ta?_Kaff?               Ta?_Kaff?            (ok)
Ta?t?                     Ta?t?                (ok)
Ta??                      Ta?                  (error)
r?st?n                     r?st?n               (ok)
relo?m?                  relo?m               (error)

Testet with Apache 1.3.3 and PHP 3.0.5 on Linux and SUN Solaris. 
My do-conf line: 
./configure --with-apache=/usr/local/src/comapache/apache_1.3.3 --with-gd=/usr/local --with-mysql --with-config-file-path

This strange behaviour is discussed in the German PHP Mailing List (archive on http://infosoc.uni-koeln.de/archive/php/), but until now we haven't found a solution. 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-11-10 22:24 UTC] rasmus
This looks like a Netscape problem to me.  At least, I was able to reproduce the problem with Netscape, but with IE5 it worked perfectly.  Can you verify that everything is fine with IE for you?

Ok, I am sure this is not a PHP bug.  Closing it.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 15 18:01:26 2019 UTC