php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9058 dir() and readdir() don't work
Submitted: 2001-02-01 16:53 UTC Modified: 2001-04-29 06:18 UTC
From: Brian dot Craigie at necs dot demon dot co dot uk Assigned:
Status: Closed Package: Directory function related
PHP Version: 4.0.5DEV OS: HP-UX 10.20
Private report: No CVE-ID: None
 [2001-02-01 16:53 UTC] Brian dot Craigie at necs dot demon dot co dot uk
Using the examples cut-n-pasted from the dir() and readdir() documentation, dir() they both return nothing.  They work ok in php3.

I see other entries in the bug database saying this issue was fixed in the cvs, but these are dated before the release of the version I'm using, so I guess they became broken again or Solaris 8 is a problem.

I'll be delighted to help debug this if someone can tell me how.

Best Regards,

Brian

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-01 20:19 UTC] sniper@php.net
I tried them examples in our Solaris 8 (sparc) with the latest CVS
and they worked just fine. 

Could you try the latest CVS snapshot from http://snaps.php.net/  
to verify if this is fixed already? And which compiler did you use to compile PHP ?

I'm using GCC 2.95.2 as we don't have that Sun Workshop CC installed
in that machine yet.

--Jani

 [2001-02-02 08:55 UTC] Brian dot Craigie at necs dot demon dot co dot uk
Oops, a big sorry, that should be HP-UX 10.20, NOT Solaris 8 - Solaris is OK.

I updated from CVS about 3 hours ago, and tried that.  It still doesn't work on HP-UX.  The compiler used is gcc 2.8.1
I'm willing to try a more recent version if that will help.

I would have tried to trace (like truss) the httpd process but I can't get a working trace on this backward (HP-UX) O/S :-(


Thanks!

Brian


 [2001-02-02 08:55 UTC] Brian dot Craigie at necs dot demon dot co dot uk
Oops, a big sorry, that should be HP-UX 10.20, NOT Solaris 8 - Solaris is OK.

I updated from CVS about 3 hours ago, and tried that.  It still doesn't work on HP-UX.  The compiler used is gcc 2.8.1
I'm willing to try a more recent version if that will help.

I would have tried to trace (like truss) the httpd process but I can't get a working trace on this backward (HP-UX) O/S :-(


Thanks!

Brian


 [2001-02-05 03:53 UTC] Brian dot Craigie at necs dot demon dot co dot uk
Oops, a big sorry, that should be HP-UX 10.20, NOT Solaris 8 - Solaris is OK.

I updated from CVS about 3 hours ago, and tried that.  It still doesn't work on HP-UX.  The compiler used is gcc 2.8.1
I'm willing to try a more recent version if that will help.

I would have tried to trace (like truss) the httpd process but I can't get a working trace on this backward (HP-UX) O/S :-(


Thanks!

Brian


 [2001-04-29 06:10 UTC] jmoore@php.net
dup of 9933
 [2001-04-29 06:18 UTC] jmoore@php.net
this is fixed in CVS please reopen report if problem persists with latest CVS.

- James
 [2004-08-09 21:11 UTC] tcroucher at erconline dot com
Right angle clamps corrected my main support problems.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 22:01:24 2020 UTC