php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9003 mod_ssl + php4.0.4pl1 crash
Submitted: 2001-01-30 10:02 UTC Modified: 2001-03-01 22:30 UTC
From: sherman dot chan at world dot net Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 4.0.4pl1 OS: Redhat 6.1
Private report: No CVE-ID: None
 [2001-01-30 10:02 UTC] sherman dot chan at world dot net
version of apach 1.3.14
version mod_ssl 2.7.1-1.3.14
version openssl 0.9.6

i compile & install apache with php4 + mod_ssl support has no problem, however when I start the apache with php4 + ssl, it crash itself with the error message found on error_log
[Wed Jan 31 01:29:45 2001] [notice] Apache/1.3.14 (Unix) PHP/4.0.4pl1 configured -- resuming normal operations
[Wed Jan 31 01:30:01 2001] [notice] caught SIGTERM, shutting down

there is no error message find on ssl_engine_log.

the apache start up ok with either ssl or php4, but can't be both.

any idea to resolve it.

thanks,
Sherman 


there is no change on php.ini, that copied from php.ini-dist
php configure options
./configure \
 --with-apxs=/usr/local/apps/apache_1.3.14/bin/apxs \
 --with-interbase=/usr/interbase \
 --with-oci8=$ORACLE_HOME \
 --with-oracle=$ORACLE_HOME \
 --with-db \
 --with-gdbm \
 --with-xml \
 --with-mhash \
 --with-openssl \
 --with-mcrypt=/usr/local/lib \
 --with-curl \
 --without-mysql \
 --enable-track-vars

apache configure option
SSL_BASE=../openssl-0.9.6 \
./configure \
--prefix=/usr/local/apps/apache_1.3.14 \
--enable-shared=max \
--enable-module=all


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-01 21:26 UTC] sniper@php.net
Could you please try to generate a GDB backtrace of the crash?
Reconfigure / compile PHP first with --enable-debug!

--Jani

 [2001-02-04 13:02 UTC] sniper@php.net
Instructions how to generate a GDB backtrace can be found here:

http://bugs.php.net/bugs-generating-backtrace.php

--Jani

 [2001-02-10 07:43 UTC] sherman dot chan at world dot net
here is GDS trace
(gdb) run -X -DSSL -f /usr/local/apps/apache_1.3.14/conf/httpd.conf
Starting program: /usr/local/apps/apache_1.3.14/./bin/httpd -X -DSSL -f /usr/local/apps/apache_1.3.14/conf/httpd.conf

Program received signal SIGILL, Illegal instruction.
0x40353715 in modf () from /usr/local/apps/apache_1.3.14/libexec/libphp4.so
(gdb) bt
#0  0x40353715 in modf () from /usr/local/apps/apache_1.3.14/libexec/libphp4.so
#1  0x6023ddff in ?? ()
#2  0x8073547 in ap_fcvt ()
#3  0x8073c0b in conv_fp ()
#4  0x8074894 in ap_vformatter ()
#5  0x8074f98 in ap_snprintf ()
#6  0x40b09fe4 in ?? () from /usr/local/apps/apache_1.3.14/libexec/libssl.so
#7  0x40b09d7e in ?? () from /usr/local/apps/apache_1.3.14/libexec/libssl.so
#8  0x40b051c7 in ?? () from /usr/local/apps/apache_1.3.14/libexec/libssl.so
#9  0x80571b9 in ap_init_modules ()
#10 0x8060d15 in standalone_main ()
#11 0x8061533 in main ()
#12 0x400b61eb in __libc_start_main (main=0x80611dc <main>, argc=5, argv=0xbffffc04, 
    init=0x804f344 <_init>, fini=0x8097a4c <_fini>, rtld_fini=0x4000a610 <_dl_fini>, 
    stack_end=0xbffffbfc) at ../sysdeps/generic/libc-start.c:90

 [2001-02-22 09:15 UTC] sherman dot chan at world dot net
further test, 
I done the exactly same configuration on RedHat 7.0, it works fine, php + mod_ssl startup perfect.  it seems the problem is relate to glibc, pthread??.  However, I have to get it work RedHat 6.1, any idea?

thanks in advance

 [2001-02-22 18:58 UTC] sniper@php.net
I think this is the old pthreadg/glibc bug. ie. you have to 
link your apache with pthread lib.

you can configure apache like this:

# LDFLAGS=-lpthread ./configure 

--Jani

 [2001-02-26 03:54 UTC] sniper@php.net
User feedback:
-----------
I try that, but it doesn't work, any version of pthread i need to 
install 1st???
-----------

This is what I have:
/lib/libpthread-0.8.so

Check that apache really is linked with pthread lib:
# ldd /usr/local/apps/apache_1.3.14/bin/httpd

--Jani


 [2001-02-26 03:57 UTC] sniper@php.net
And as you're using OCI8  make sure you have all the required
environment variables set ( http://www.php.net/oci8 ) before
starting Apache.

--Jani

 [2001-03-01 22:30 UTC] sniper@php.net
User feedback:
-----------
Yes, it does work ok without mod_ssl, further testing I done last night, I
build a redhat 6.1 box and rebuild the kernal to 2.2.18, then do the exactly
same step to build apache + mod_ssl + php4, guess what, it works.  I haven't
try to execute that image on radhat 6.1 with org. kernal, but i'll do that
today, and see does it run.   by the way, i did add --enable-debug on php4
while i re-compile it.  if I didn't do it i won't see those back trace at
all.  
-----------

As this has nothing to do with PHP 4 -> Closed.

--Jani

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Sep 20 19:01:26 2018 UTC