php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8984 Intermittent TNS-12154 (cannot resolve service name) error
Submitted: 2001-01-29 11:27 UTC Modified: 2001-02-18 06:49 UTC
From: danab at mail dot gonext dot co dot il Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.1pl2 OS: Solaris 2.6
Private report: No CVE-ID: None
 [2001-01-29 11:27 UTC] danab at mail dot gonext dot co dot il
This is basically a rehash of bugs #4307, #5569 & #8232.

Running PHP 4.0.1pl1 as an Apache 3.1.12 module, I often run into this problem during OCILogon() calls.

Regarding the solution to #4307 - ALL oracle-related env vars I can think of are set before Apache is started. The /etc/rc3.d script that starts apache sources a file setting the lot of them before starting the server.

The solution I saw in #5569 - make user "nobody" a member of group "dba" - is, frankly, unacceptable (and I haven't even tried it). I have a public portal to run, and can't afford the secrity hole.

Essentially, I am also reiterating bug report #8232, which I see has remained open for over a month now.

The problem appears intermittently in virtually all places that OCILogon() is used, so I see now point in osting yet another code example.

Any help will be appreciated.

Thanks,

Dan Abarbanel,
GoNext Ltd.
Israel

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-30 04:49 UTC] sniper@php.net
reclassified

 [2001-02-18 06:42 UTC] thies@php.net
please upgrade to 4.0.4pl1 there was a bug in the apache 
module that could be the cause for TNS-12154  fixed a long 
time ago. 

from NEWS:

- Apache module would sometimes close a wrong 
file-descriptor. (Sascha)




 [2001-02-18 06:49 UTC] thies@php.net
forgot to close

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 13:05:53 2022 UTC