php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8983 gd tries to use gif functions
Submitted: 2001-01-29 11:16 UTC Modified: 2001-01-29 18:32 UTC
From: ben at efros dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0.4pl1 OS: slackware 7 w/2.4.0
Private report: No CVE-ID: None
 [2001-01-29 11:16 UTC] ben at efros dot com
I've installed gd 1.8.3 and of course it does not have gif support anymore.

Yet, still configure defines HAVE_GD_GIF, saying that it detected the support.

Compile of course fails when HAVE_GD_GIF is defined and the functions are not really available.

Can anyone else reproduce?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-29 17:31 UTC] ben at efros dot com
There seems to be some errors while trying to compile php (with gd).

I just removed the few gif functions from ext/gd/gd.c and compiled fine.

Maybe it would be a good idea to finally remove these old functions since gd no longer supports gif and its hard to find an old version that does (especially since png is fine for most things).
 [2001-01-29 17:59 UTC] ben at efros dot com
OK OK, ignore all that other crap I've already posted.... I REALLY DONT KNOW WHAT I AM TALKING ABOUT... 

Anyways, got trouble compiling 4.0.4pl1 and also the latest snapshot....

gcc  -I. -I/root/webserv/php4-200101291345/ext/gd -I/root/webserv/php4-200101291345/main -I/root/webserv/php4-200101291345 -I/root/webserv/apache_1.3.14/src/include -I/root/webserv/apache_1.3.14/src/os/unix -I/root/webserv/php4-200101291345/Zend -I/root/webserv/php4-200101291345/ext/mysql/libmysql -I/root/webserv/php4-200101291345/ext/xml/expat/xmltok -I/root/webserv/php4-200101291345/ext/xml/expat/xmlparse -I/root/webserv/php4-200101291345/TSRM  -DXML_BYTE_ORDER=12 -g -O2  -c gd.c && touch gd.lo
gd.c: In function `php_if_imagecreatefromgif':
gd.c:709: `gdImageCreateFromGif' undeclared (first use in this function)
gd.c:709: (Each undeclared identifier is reported only once
gd.c:709: for each function it appears in.)
gd.c:709: `gdImageCreateFromGifCtx' undeclared (first use in this function)
gd.c: In function `php_if_imagegif':
gd.c:891: `gdImageGif' undeclared (first use in this function)
make[3]: *** [gd.lo] Error 1
make[3]: Leaving directory `/root/webserv/php4-200101291345/ext/gd'
 [2001-01-29 18:32 UTC] sniper@php.net
You have some old gd.h laying around in your system. 
Just remove every instance of the old library, then 'make install' again
for gd. Then go to the php4 source directory, delete config.cache, reconfigure
(use --with-gd=/path/to/gd/install/dir, e.g. --with-gd=/usr/local) and
do 'make clean ; make ; make install' and you should have working PHP again.

And if this doesn't help, ask further questions on php-install@lists.php.net 
for support.

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 11:01:24 2020 UTC