php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8865 App launching with hotkeys delayed
Submitted: 2001-01-23 12:28 UTC Modified: 2002-05-24 20:13 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (66.7%)
From: gvz at eucalipto dot net Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.1.0 OS: Windows 95b, 98
Private report: No CVE-ID: None
 [2001-01-23 12:28 UTC] gvz at eucalipto dot net
With PHP as module, several second delay (totally freezing windows) when launching applications using Windows' hot-keys. (Seems related to bug 8864)

This tried with PHP 4.0.1 up to 4.0.5dev.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-11 21:07 UTC] sniper@php.net
Does this still happen?

--Jani

 [2001-05-12 10:53 UTC] gvz at eucalipto dot net
Sure does! I haven't tried php 4.0.5-dev on this, but 4.0.4 pl1 does. I still think it must be related to bug 8864 (which died as I didn't give any prompt feedback, but is also real).

It's not a Win95 issue only, it also happens on Win98 (haven't tried Win Me).
 [2001-05-12 12:49 UTC] derick@php.net
Can you please try it with 4.0.5, or preferrable php-4.0.6dev ?
 [2001-05-12 20:02 UTC] gvz at eucalipto dot net
I just tried with 4.0.5, and it happens just the same. Also the condition I explained in bug 8864 still holds constant. 

More info:
-Win95 SR-2, Winsock 2 patch, IP (for ws2) patch, TCP (for ws2) patch, comdlg401 patch, DCOM95 installed.
-Apache 1.3.12, no bells, no whistles, just out-of-the-box
-PHP 4.0.5 (binary download from php.net)
-NO extensions loaded, just plain PHP.
-Not related to any particular code, this is is a condition on windows itself: apache and php run beautifully. The trouble occurs for other apps when apache runs with the apache-php module.
-The slowing down of apps launched using hotkeys is NOT related to any particular application, but is a windows delay. The delay is for the launching (5-7 sec. delay with freeze-up), not for normal running once an app has been launched. If I get things running, everything works ok.
-No apparent relation to any other running app: I've tried shutting down everything (yhat is, only explorer running), and then launching apache with php as a module, and the condition persists just the same.

I'll try 4.0.6dev on a win98 box and report back.

Hope this helps.
Gonzalo.
 [2001-06-14 20:40 UTC] sniper@php.net
Does this happen if you comment out the PHP loadmodule
statement in apache conf? (and stop / start apache)



 [2001-07-02 17:47 UTC] gvz at eucalipto dot net
No. It only happens when PHP is loaded as a module. If it happens when used as CGI it is not noticeable, since it runs for just a few moments. Probably a web server with lots of traffic could cause the same problem, but mine is a small intranet so I wouldn't notice.
 [2001-12-20 09:51 UTC] lobbin@php.net
Can you try this with 4.1.0?

R.
 [2001-12-20 11:15 UTC] gvz at eucalipto dot net
Still happens. Just exactly like 4.0.6. My actual setup: Apache 1.3.20 (release 10320100), PHP 4.1.0 downloaded from www.php.net, MySQL 3.23.29 (tried also stopping MySQL, and still happens). No extra modules loaded on PHP, nothing special on Apache (default instalation) besides PHP loaded as module, Win 98 SE in spanish. All this on a Pentium II 450, 128 MB RAM

Anything else I could test to help?
 [2002-02-11 01:35 UTC] steven at kit dot i989 dot net
I also have such problem and looking for solution.
Still no solution at this time?
 [2002-05-24 20:13 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-10-06 16:13 UTC] nobs at softhome dot net
Still happens for me with PHP 4.2.3.

I'm using PHP 4.2.3 (no extensions), as a module with Apache 1.3.26, on Windows 98 (English).  Hardware: Pentium II 350, 320 MB RAM.

This doesn't actually freeze the whole system for 5-7 seconds, but rather the shell--notably the task bar (including start button and tray area) and the desktop don't respond.  Other running applications continue to be responsive.  I can even load PHP'd documents from my local Apache server during the delay period.
 [2002-10-08 10:27 UTC] nobs at softhome dot net
I've also found that the same set of conditions (PHP 4.2.3 as sapi module with Apache 1.3.26 on Windows 98) causes the ancient Eudora Light 3.0.6 e-mail client to hang as it starts up--completely, it must be killed.  Anyone have a copy of Eudora 3.0.x and want to try this on a later version of Windows?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 16 07:01:27 2019 UTC