php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8815 allow_fopen_url = On & include("URL") don't work
Submitted: 2001-01-19 21:39 UTC Modified: 2001-04-10 09:48 UTC
From: mklinux at oceanbay dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.4pl1 OS: Intel/Linux (GNU)
Private report: No CVE-ID: None
 [2001-01-19 21:39 UTC] mklinux at oceanbay dot com
After compiling PHP 4.0.4pl1 with 

./configure" \
	--prefix=/usr \
	--with-config-file-path=/usr/lib" \
	--with-apache=../apache_1.3.14 \
	--with-mysql=/usr/local/mysql \
	--with-pgsql=/usr/local/pgsql \
	--with-gd \
	--with-jpeg-dir \
	--with-t1lib \
	--with-ttf \
	--with-mhash \
	--with-openssl=/usr/local/ssl \
	--with-curl \
	--with-imap=../imap-2000a \
	--with-mm \
	--with-zlib \
	--with-bz2 \
	--enable-gd-imgstrttf \
	--enable-track-vars \
	--enable-magic-quotes \
	--enable-trans-sid \
	--enable-sockets \
	--enable-ftp \
	--enable-bcmath \
	--enable-calendar \
	--with-gnu-ld

and then making and installing into Apache_1.3.14, and running it, when tring to include("URL"); or include("localpath?test=test"); it will give the result of "Error No Data Sent".

also

when in docs/test/ and tring to include a file like this. include("../test2/test/php"); it will fail and cannot find the file.

in the configuration (php.ini) there is a allow_url_fopen = On. and in phpinfo it says allow_url_fopen local value of '1' and a master value of '1'. This is a stock php.ini (except the error_log was set to a file and the requirted changes for 'imp/horde'. Other than that it is the stock config.

the system is Glibc 2.1.3, Linux Kernel 2.4.

any help with this is greatly appriciated.

thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-27 21:08 UTC] sniper@php.net
Does this simple example work for you:

<?php include("http://www.php.net"); ?>

If so, you are propably doing something wrong or have misunderstood
the use of include()

--Jani
 [2001-01-28 01:45 UTC] mklinux at oceanbay dot com
tring that gives me the same 'document contains no data' in netscape.

There is a firewall so it cannot get out of port 80. But when tring it on another domain on the same web server. I get the same error, another domain on a different machines gives the same error.

I am going to be compiling and installing PHP4.0.4pl1 on my local servers here to se if the same error occurs.

I hope you have some insight.
 [2001-03-10 20:55 UTC] sniper@php.net
Please try the latest CVS snapshot from http://snaps.php.net/ as I can't reproduce this bug with it.

--Jani

 [2001-04-10 09:48 UTC] sniper@php.net
No feedback. If this happens with soon to be released PHP 4.0.5 too, reopen this bug report.

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 13:01:27 2024 UTC