php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #8797 There is no way to use REC_VERSION transaction parameter
Submitted: 2001-01-19 02:29 UTC Modified: 2003-06-14 13:26 UTC
From: iamhere at online dot ru Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.2.2 OS: Any
Private report: No CVE-ID:
 [2001-01-19 02:29 UTC] iamhere at online dot ru
I found, there is no way to use REC_VERSION constant in transaction
parameters. This constant is using with COMMITTED only.

Without REC_VERSION (NO_REC_VERSION is default) interbase raise error, when
COMMITTED transaction select records, which is modified, but not committed.

It seems not very difficult to add new constant IBASE_REC_VERSION and to add
bit checking in "ibase_trans" function...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-13 23:50 UTC] iliaa@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-08-15 12:24 UTC] iamhere at online dot ru
php 4.2.2. - bug is still here
 [2002-08-15 12:30 UTC] iamhere at online dot ru
php 4.2.2. - bug is still here
 [2002-08-15 13:06 UTC] kalowsky@php.net
Moving this to a feature request because thats really what it is.  I looked at adding it, and while doing the constant isn't hard, doing the check in the function is... as I have no clue.  
 [2003-06-14 13:26 UTC] daniela@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 00:01:21 2014 UTC