php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8783 mssql_query() function returns empty result after succesfull UPDATE or DELETE
Submitted: 2001-01-18 10:37 UTC Modified: 2002-06-18 18:21 UTC
From: yuri_kruglov at autosystems dot kiev dot ua Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.4pl1 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-01-18 10:37 UTC] yuri_kruglov at autosystems dot kiev dot ua
$foo = mssql_query("DELETE FROM session WHERE ABS(DATEDIFF(hh,GETDATE(),LastUsed)) > 12",$db) or mssql_die();


Query executes succesfully? but $foo is empty and mssql_die() is called !

php.ini is a default, php4_mssql70.dll is uncommented.

Error happens in both CGI and ISAPI modes.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-09 13:27 UTC] sniper@php.net
Duplicate of #8777

 [2002-06-18 18:21 UTC] sniper@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 07:01:28 2024 UTC