php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8753 Dynamic load library error
Submitted: 2001-01-17 03:19 UTC Modified: 2001-06-22 11:51 UTC
From: ojo at gic dot sk Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
 [2001-01-17 03:19 UTC] ojo at gic dot sk
dl("interbase.so")

Invalid library (maybe not a PHP library) ?nterbase.so?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-14 16:37 UTC] sniper@php.net
How did you compile PHP ? What was the configure line used?

 [2001-06-15 02:05 UTC] ojo at gic dot sk
how did I compile PHP?
# ./configure --enable-versioning --enable-track-vars 
--with-imap=/usr/local/src/imap-4.7 
--with-apxs=/usr/local/apache/bin/apxs
# make
# make install

and modul (for example pgsql):
# mkdir /tmp/newext
# cd /tmp/newext/
# cp -rp /usr/local/src/php-4.0.5/ext/pgsql/* .
# ./configure
# make install
# cd /usr/local/lib/php/extensions/
# cp no-debug-non-zts-20001222/pgsql.so .
# pico /usr/local/lib/php.ini // uncommenting 
extension=pgsql.so
# php

PHP Warning:  Invalid library (maybe not a PHP library) 
'pgsql.so'  in Unknown on line 0

Using RH7.1, PHP 4.0.5


 [2001-06-19 09:54 UTC] sniper@php.net
You seem to be skipping one important step here: phpize
Try reading these instructions found in the package:

README.SELF-CONTAINED-EXTENSIONS

And exactly WHY do you want to do this? 
It's better to configure with everything in the first place..

Also, update to 4.0.5 as it has some fixes regarding this issue.

--Jani

 [2001-06-19 09:55 UTC] sniper@php.net
And if you really want to have shared extensions, you can
compile them same time you compile main PHP by configuring like this:

--with-pgsql=shared

--Jani

 [2001-06-20 01:05 UTC] ojo at gic dot sk
Sorry, I just forgot to write down phpsize, but I used it. 
There is a still same error, even in version 4.0.5, plus 
there is an error vhen stand-alone program finishing its 
executing, so changes are not writing in database (even if 
error - segmentation fault -  occurs after ibase_close 
function). That's why I still want to use older version.

 [2001-06-20 01:09 UTC] ojo at gic dot sk
I can try --with-pgsql=shared, but what if I want to add 
support for mysql? Do I need to recompile php? I think 
modules can solve this problem, but this is not working 
(not on my PC). sorry.

 [2001-06-21 14:17 UTC] sniper@php.net
Let's open this again, can you please try the 
PHP 4.0.6 RELEASE (not official yet) from here:

http://www.php.net/~andi/php-4.0.6.tar.gz

There have been some changes in everything and one pgsql
crash bug is fixed in this release.

--Jani

 [2001-06-22 02:10 UTC] ojo at gic dot sk
Now it works. (Only interbase and postgres not mysql and 
sybase-ct, but it works).

thanx.

 [2001-06-22 11:51 UTC] sniper@php.net
Both mysql and sybase-ct are fixed in CVS now and they
should build as self-contained extensions.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC