php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8713 Compatible with InterBase ver.<6.0
Submitted: 2001-01-15 10:18 UTC Modified: 2002-05-24 20:35 UTC
From: yarcev at kamkabel dot ru Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.4 OS: Windows NT 4
Private report: No CVE-ID: None
 [2001-01-15 10:18 UTC] yarcev at kamkabel dot ru
Question:     Is PHP 4.0.4 work with InterBase Database under InterBase 5.6 (ver. < 6.0)?

Comment:

Would Php work with IneterBase ver < 6.0    ( if i need change version of gds32.dll ) ?


I install PHP 4.0.4 for Win32 and use his under Apache 3.14 at my computer
(Operating System on my computer is Windows NT Workstation 4, ServicePack 4)
Also i has installed InterBase 5.6 (Server+Client)
and i want use Php as Script language for dinamically generating HTML
on bases Request to InterBase Database (for example, this database place in Local Network)
I'am configure my Apache web server, and edit my php.ini

After start Apache i recieve error message "Order number 261 not found in library gds32.dll"
and as result PHP-function for IBase don't work (extention php_interbase in this cause not be
loaded when Apache is Start)

If i change my gds32.dll (version='WI-V5.6.0.29' by Interbase Software Group) on
gds32.dll (version='6.0.0.530' by Inprise Corporation) as result
in second string of this php code:
    $dbh = ibase_connect ('leopard:/intrbase/kkss_test.gdb', 'sysdba', 'masterkey');
    $stmt = 'SELECT * FROM n_unit';    $sth = ibase_query ($dbh, $stmt);
i has error Message from InterBase
Dinamic SQL Error -901 and i think that this cause by mean change version gds32.dll
(as comment: My InterBase Software work not always correctly then i chage my gds32.dll)

Is PHP 4.0.4 work with InterBase Database under InterBase 5.6?


My Apache httpd.conf file

ServerType standalone
ServerRoot "D:/Program Files/Apache Group/Apache"
PidFile logs/httpd.pid
ScoreBoardFile logs/apache_runtime_status
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MaxRequestsPerChild 0
ThreadsPerChild 50
Port 80
ServerAdmin name@host.ru
DocumentRoot "D:/Program Files/Apache Group/Apache/htdocs"
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory "D:/Program Files/Apache Group/Apache/htdocs">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
<IfModule mod_userdir.c>
    UserDir "D:/Program Files/Apache Group/Apache/users/"
</IfModule>
<IfModule mod_dir.c>
    DirectoryIndex index.html
</IfModule>
AccessFileName .htaccess
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>
UseCanonicalName On
<IfModule mod_mime.c>
    TypesConfig conf/mime.types
</IfModule>
DefaultType text/plain
<IfModule mod_mime_magic.c>
    MIMEMagicFile conf/magic
</IfModule>
HostnameLookups Off
ErrorLog logs/error.log
LogLevel warn
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
CustomLog logs/access.log common
ServerSignature On
<IfModule mod_alias.c>
    Alias /icons/ "D:/Program Files/Apache Group/Apache/icons/"
    <Directory "D:/Program Files/Apache Group/Apache/icons">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ "D:/Program Files/Apache Group/Apache/cgi-bin/"



LoadModule php4_module d:/php/sapi/php4apache.dll
AddType application/x-httpd-php .php4
ScriptAlias /php4/ "D:/php/"
Action application/x-httpd-php4 "/php4/php.exe"
AddType application/x-httpd-php4 .php



    <Directory "D:/Program Files/Apache Group/Apache/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>

</IfModule>

.......

My PHP.ini is like this:

[PHP]
engine			=	On
short_open_tag	=	On	
asp_tags		=	Off 
precision		=	14
y2k_compliance	=	Off
output_buffering	= Off
output_handler		=
implicit_flush		= Off
allow_call_time_pass_reference	= On
safe_mode		=	Off
safe_mode_exec_dir	=
safe_mode_allowed_env_vars = PHP_	
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions	=
highlight.string	=	#DD0000
highlight.comment	=	#FF8000
highlight.keyword	=	#007700
highlight.bg		=	#FFFFFF
highlight.default	=	#0000BB
highlight.html		=	#000000
expose_php	=	On
max_execution_time = 30     
memory_limit = 8M			
error_reporting	=	E_ALL & ~E_NOTICE
display_errors	=	On
display_startup_errors = Off
log_errors		= Off
track_errors	=	Off
warn_plus_overloading	=Off
variables_order		=	"EGPCS"	
register_globals	=	On
register_argc_argv	=	On
post_max_size		=	8M
gpc_order			=	"GPC"
magic_quotes_gpc	=	On		
magic_quotes_runtime=	Off		
magic_quotes_sybase	=	Off		
auto_prepend_file	=
auto_append_file	=
default_mimetype = "text/html"
include_path	=                   
doc_root		=		
user_dir		=		
extension_dir	=	D:\PHP\extensions\
enable_dl		= On
file_uploads	= On
upload_max_filesize = 2M
allow_url_fopen = On
extension=php_bz2.dll
extension=php_ctype.dll
extension=php_cpdf.dll
extension=php_cybercash.dll
extension=php_db.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_domxml.dll
extension=php_dotnet.dll
extension=php_exif.dll
extension=php_filepro.dll
extension=php_gd.dll
extension=php_iisfunc.dll
extension=php_imap.dll
extension=php_interbase.dll
extension=php_java.dll
extension=php_mhash.dll
extension=php_pdf.dll
extension=php_pgsql.dll
extension=php_printer.dll
extension=php_snmp.dll
extension=php_zlib.dll
define_syslog_variables	= Off
SMTP			=	localhost
sendmail_from	=	me@localhost.com
debugger.host	=	localhost
debugger.port	=	7869
debugger.enabled	=	False
sql.safe_mode	=	Off
odbc.allow_persistent	=	On
odbc.check_persistent  = 	On
odbc.max_persistent	=	-1
odbc.max_links			=	-1
odbc.defaultlrl	=	4096
odbc.defaultbinmode	= 	1
 . . . . . . .


I








Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-15 23:05 UTC] yarcev at kamkabel dot ru
Probably i need older version of files php_interbase.dll (who compatible with InterBase 5.6) (php_interbase.dll that i download from www.php.net use gds32.dll for InterBase 6.0). If Thats right then, please send to me by e-mail: where i can download correctly version of php_interbase.dll, or maybe i need install PHP 3 for supporting InterBase 5.6 ?
 [2002-05-24 20:35 UTC] derick@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 13:01:26 2019 UTC