php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8678 microtime() does not work very well
Submitted: 2001-01-12 11:52 UTC Modified: 2001-04-27 20:25 UTC
From: nevries at ucc dot nl Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.4 OS: Windows ME
Private report: No CVE-ID: None
 [2001-01-12 11:52 UTC] nevries at ucc dot nl
Under Windows ME microtime() does not work very well. 

Example output: 
979317843.96524 
979317843.9754 
979317843.98553 
979317843.99569 
979317843.00009 !!!! 
979317843.01011 
979317843.0202 
979317843.03033 
979317843.04045 
979317843.05056 
979317843.06069 
979317843.07079 
979317843.08082 
979317843.09089 
979317843.10126 
979317844.10589 !!!! 
979317844.11597 
979317844.13162 
979317844.14164 
979317844.1518 
979317844.16193 

It is almost as if 2 completely different clocks are used.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-13 20:43 UTC] sniper@php.net
Duplicate of #4968

 [2001-04-27 20:25 UTC] sniper@php.net
Fixed in CVS.

--Jani

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC