php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8672 Crash when returning a variable from function as argument
Submitted: 2001-01-12 05:30 UTC Modified: 2001-05-16 10:35 UTC
From: bf at ez dot no Assigned:
Status: Closed Package: Variables related
PHP Version: 4.0.4 OS: Redhat Linux 6.2
Private report: No CVE-ID: None
 [2001-01-12 05:30 UTC] bf at ez dot no
I had code like this:
$user = new eZUser( $session->variable("AuthenticatedUser" ) );

And I noticed now that this creates a segfault in php.

The workaround is changing the code to:

$val = $session->variable( "AuthenticatedUser" );
$user = new eZUser( $val );


The code worked with php-4.0.3pl1 and has worked with 
4.0.4, but it's reproduceable and I think it's a PHP bug.

The eZSession::variable() function returns a string value.

I've tested it with 4.0.4pl1 and the bug is still there.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-28 14:45 UTC] derick@php.net
Can you try to reprocude this when php 4.0.5 will be released next week? 
 [2001-05-16 01:02 UTC] sniper@php.net
Does this happen with PHP 4.0.5 or not?

--Jani

 [2001-05-16 10:35 UTC] bf at ez dot no
I can't reproduce this with 4.0.5. Seems to be fixed ;)

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 19 16:01:26 2019 UTC