php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8654 Servlet.init() for servlet php threw exception
Submitted: 2001-01-11 10:08 UTC Modified: 2001-03-09 21:12 UTC
From: dwilliams at anydevice dot com Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0.4 OS: Linux
Private report: No CVE-ID: None
 [2001-01-11 10:08 UTC] dwilliams at anydevice dot com
ENV: Tomcat-4.0-b1,Linux,jdk1.3,PHP 4.0.4. 
This error happens when i access any *.php files.

A Servlet Exception Has Occurred
Exception Report:
javax.servlet.ServletException: Servlet.init() for servlet php threw exception 
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:774)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:544)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:227)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:196)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2041)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
at org.apache.catalina.valves.ValveBase.invokeNext(ValveBase.java:242)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:414)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:975)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:159)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:818)
at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:897)
at java.lang.Thread.run(Thread.java:484)

Root Cause:
java.lang.UnsatisfiedLinkError: no php4 in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1312)
at java.lang.Runtime.loadLibrary0(Runtime.java:749)
at java.lang.System.loadLibrary(System.java:820)
at net.php.reflect.loadLibrary(reflect.java:34)
at net.php.reflect.(reflect.java:29)
at net.php.servlet.init(servlet.java:131)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:755)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:544)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:227)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:196)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2041)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
at org.apache.catalina.valves.ValveBase.invokeNext(ValveBase.java:242)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:414)
at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:975)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:159)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:977)
        at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:818)
        at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:897)
        at java.lang.Thread.run(Thread.java:484)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-11 11:58 UTC] chrisv@php.net
Is libphp4.so installed in your java.library.path? If it isn't, it's throwing the exception because it can't find your PHP module. Try putting the library into jdk1.3/jre/lib/libphp4.so or any other place where Java knows to look for it and it should work.
 [2001-03-09 21:12 UTC] sniper@php.net
No feedback.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC