php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8645 makeconfig warning/PHP doesn't work
Submitted: 2001-01-10 20:48 UTC Modified: 2001-01-30 04:41 UTC
From: rstevens at publichost dot com Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.0 Latest CVS (10/01/2001) OS: RedHat Linux 6.2
Private report: No CVE-ID: None
 [2001-01-10 20:48 UTC] rstevens at publichost dot com
I retrieved the 4.0.5 CVS source.  There is no "configure"
script, so I ran "buildconfig".  I get two errors from there
indicating something was checked before the thing it was
depending on was included.  It builds a "configure" script,
however.

I ran the configure script and everything appeared fine.
However, after integration with Apache, Apache reports the
PHP4 module as being installed but PHP does not work at all.

System:
RedHat Linux 6.2 with all current patches.  Kernel 2.2.16-3.
Intel Celeron @ 400MHz, 128MB RAM.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-11 19:00 UTC] sniper@php.net
What was the configure line you used? And have you updated CVS since?
It works for me just fine and I  have almost every configure option included
in my configure line..

My recipe is this :

# cvs update
# ./cvsclean
# ./buildconf
# ./configure (and a lot of options! :)
# make clean ; make 2> errors.txt 

And if make is ok (ie. no fatal errors in errors.txt):

# make install

--Jani




 [2001-01-30 04:41 UTC] sniper@php.net
reopen if problem still exists with latest CVS.
(works for me just fine.. :)

--Jani

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 17:03:54 2023 UTC