php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8635 Missing symbols when linked with ucd-snmp 4.2
Submitted: 2001-01-10 08:18 UTC Modified: 2001-01-11 08:21 UTC
From: marc dot daumas at urssaf dot fr Assigned:
Status: Closed Package: SNMP related
PHP Version: 4.0.4 OS: Suse Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
47 - 19 = ?
Subscribe to this entry?

 
 [2001-01-10 08:18 UTC] marc dot daumas at urssaf dot fr
When you try to build PHP-4.0.4 with libsnmp 4.2 installed
on your system, libphp4.so is build but des_* symbols are 
missing.
when Apache tries to load the lib
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/libsnmp-0.4.2.so: undefined symbol: des_cbc_encrypt
Applications dynamicaly linked with libsnmp 4.2 must be linked with libdes.a
How can I add that library ?                                        

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-11 08:21 UTC] sniper@php.net
You need openssl. Add --with-openssl=/path/to/install/dir into your configureline. (you have to have openssl 
installed in your system)

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 25 08:01:27 2019 UTC